summaryrefslogtreecommitdiff
path: root/games-arcade/spacerider/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:58:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:58:29 +0100
commit0cf2f20608308acdf3cb922c3736446bbd8f3388 (patch)
tree07815070629c7c11000a7f51ceb8ccbccb49a809 /games-arcade/spacerider/files
parent1798c4aeca70ac8d0a243684d6a798fbc65735f8 (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-arcade/spacerider/files')
-rw-r--r--games-arcade/spacerider/files/spacerider-0.13-font.patch14
-rw-r--r--games-arcade/spacerider/files/spacerider-0.13-gcc41.patch10
-rw-r--r--games-arcade/spacerider/files/spacerider-0.13-gcc49.patch22
-rw-r--r--games-arcade/spacerider/files/spacerider-0.13-gentoo.patch27
-rw-r--r--games-arcade/spacerider/files/spacerider-0.13-ovflfix.patch11
5 files changed, 0 insertions, 84 deletions
diff --git a/games-arcade/spacerider/files/spacerider-0.13-font.patch b/games-arcade/spacerider/files/spacerider-0.13-font.patch
deleted file mode 100644
index 87732a106633..000000000000
--- a/games-arcade/spacerider/files/spacerider-0.13-font.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-Ugly brute-force method for avoiding a double-free segfault on exit.
-Better patch welcome.
-
---- a/spacerider.cpp.orig 2015-03-31 23:24:17.770966147 -0400
-+++ b/spacerider.cpp 2015-03-31 23:24:41.592174463 -0400
-@@ -306,8 +306,6 @@
- /* free screen */
- SDL_FreeSurface(screen);
- }
-- /* call the TTF-Library cleanup function */
-- TTF_Quit();
-
- /* call the NET-Library cleanup function */
- SDLNet_Quit();
diff --git a/games-arcade/spacerider/files/spacerider-0.13-gcc41.patch b/games-arcade/spacerider/files/spacerider-0.13-gcc41.patch
deleted file mode 100644
index e5524b6e6430..000000000000
--- a/games-arcade/spacerider/files/spacerider-0.13-gcc41.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- a/spacerider.cpp.old 2007-02-18 11:25:38.000000000 +0100
-+++ b/spacerider.cpp 2007-02-18 11:27:00.000000000 +0100
-@@ -17,6 +17,7 @@
- #include <unistd.h>
- }
-
-+int send_score_thread(void *param);
-
- Spacerider::Spacerider(const int argc, char *argv[]) : fullscreen(FULLSCREEN), game_over(false), online_highscore(ONLINE_HIGHSCORE), score_sent(false), name_input(true), highscore_thread_started(false), scroll(0), last_enemy(0), score(0), lives(LIVES), fps(FPS)
- {
diff --git a/games-arcade/spacerider/files/spacerider-0.13-gcc49.patch b/games-arcade/spacerider/files/spacerider-0.13-gcc49.patch
deleted file mode 100644
index b4d5ca6d5764..000000000000
--- a/games-arcade/spacerider/files/spacerider-0.13-gcc49.patch
+++ /dev/null
@@ -1,22 +0,0 @@
---- a/effect.cpp.orig 2015-03-31 22:36:53.336131373 -0400
-+++ b/effect.cpp 2015-03-31 22:37:04.359755281 -0400
-@@ -18,7 +18,7 @@
- void Effect::add(const int x, const int y)
- {
- object_struct *effect;
-- if((effect = add_object(x, y)) == NULL)
-+ if((effect = add_object(x, y, 0, 0)) == NULL)
- {
- return;
- }
---- a/object.h.orig 2015-03-31 22:35:22.939214561 -0400
-+++ b/object.h 2015-03-31 22:37:19.654233441 -0400
-@@ -172,7 +172,7 @@
- return object->next;
- }
-
--template <class T>struct Object<T>::object_struct *Object<T>::add_object(const int x, const int y, const int speedx = 0, const int speedy = 0)
-+template <class T>struct Object<T>::object_struct *Object<T>::add_object(const int x, const int y, const int speedx, const int speedy)
- {
- object_struct *object;
-
diff --git a/games-arcade/spacerider/files/spacerider-0.13-gentoo.patch b/games-arcade/spacerider/files/spacerider-0.13-gentoo.patch
deleted file mode 100644
index ecfdcc513cd0..000000000000
--- a/games-arcade/spacerider/files/spacerider-0.13-gentoo.patch
+++ /dev/null
@@ -1,27 +0,0 @@
---- a/Makefile
-+++ b/Makefile
-@@ -3,12 +3,12 @@
- BINDIR=/usr/bin/
- MANDIR=/usr/share/man/man1/
- DATADIR=/usr/share/games/spacerider/
--CXX=g++
-+CXX?=g++
- CP=cp
- MKDIR=mkdir -p
- INSTALL=install
- RM=rm -f
--CXXFLAGS=-Wall -fomit-frame-pointer -O3 `sdl-config --cflags`
-+CXXFLAGS+=$(shell sdl-config --cflags)
- OBJS=main.o globals.o spacerider.o music.o sprite.o enemy.o effect.o visible.o box.o features.o font.o image.o bullet.o
- OUTPUT=spacerider
- LIBS=`sdl-config --libs` -lSDL_image -lSDL_ttf -lSDL_mixer -lSDL_net -lSDL_gfx
-@@ -22,8 +22,7 @@
-
-
- $(OUTPUT): $(OBJS)
-- $(CXX) $(CXXFLAGS) -o $(OUTPUT) $(OBJS) $(LIBS)
-- strip $(OUTPUT)
-+ $(CXX) $(CXXFLAGS) $(LDFLAGS) -o $(OUTPUT) $(OBJS) $(LIBS)
-
- %.o: %.cpp
- $(CXX) $(CXXFLAGS) -c $<
diff --git a/games-arcade/spacerider/files/spacerider-0.13-ovflfix.patch b/games-arcade/spacerider/files/spacerider-0.13-ovflfix.patch
deleted file mode 100644
index c590400f649f..000000000000
--- a/games-arcade/spacerider/files/spacerider-0.13-ovflfix.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/spacerider.cpp.old 2010-10-29 10:12:19.000000000 +0200
-+++ b/spacerider.cpp 2010-10-29 10:13:47.000000000 +0200
-@@ -112,7 +112,7 @@
- break;
- case 'n':
- /* specify a name for the online-highscore */
-- strncpy(name, optarg, 128);
-+ strncpy(name, optarg, sizeof (name));
- online_highscore = true;
- break;
- case 't':