summaryrefslogtreecommitdiff
path: root/games-arcade/sdlsasteroids/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-arcade/sdlsasteroids/files
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-arcade/sdlsasteroids/files')
-rw-r--r--games-arcade/sdlsasteroids/files/sdlsasteroids-3.0.1-gcc43.patch11
-rw-r--r--games-arcade/sdlsasteroids/files/sdlsasteroids-3.0.1-ldflags.patch11
2 files changed, 22 insertions, 0 deletions
diff --git a/games-arcade/sdlsasteroids/files/sdlsasteroids-3.0.1-gcc43.patch b/games-arcade/sdlsasteroids/files/sdlsasteroids-3.0.1-gcc43.patch
new file mode 100644
index 000000000000..9863f0c051e9
--- /dev/null
+++ b/games-arcade/sdlsasteroids/files/sdlsasteroids-3.0.1-gcc43.patch
@@ -0,0 +1,11 @@
+--- a/src/sbitmap.h
++++ b/src/sbitmap.h
+@@ -36,7 +36,7 @@
+ void LoadImage(char* path);
+ void LoadSurface(SDL_Surface* surface);
+
+- void put(float x, float y, float rotate = 1.0f, float rotate = 1.0f, float layer = 0.0f);
++ void put(float x, float y, float sf = 1.0f, float rotate = 1.0f, float layer = 0.0f);
+ void putA(float x, float y, float layer = 0.0f, float alpha = 1.0f);
+
+ inline float width() const
diff --git a/games-arcade/sdlsasteroids/files/sdlsasteroids-3.0.1-ldflags.patch b/games-arcade/sdlsasteroids/files/sdlsasteroids-3.0.1-ldflags.patch
new file mode 100644
index 000000000000..581010b51388
--- /dev/null
+++ b/games-arcade/sdlsasteroids/files/sdlsasteroids-3.0.1-ldflags.patch
@@ -0,0 +1,11 @@
+--- a/src/Makefile.old 2010-09-22 08:44:57.000000000 +0200
++++ b/src/Makefile 2010-09-22 08:45:43.000000000 +0200
+@@ -26,7 +26,7 @@
+
+
+ $(SASTEROIDS): $(SASTEROIDS_O)
+- g++ -Wall -o $(SASTEROIDS) $(SASTEROIDS_O) $(DEFINES) $(DEBUG) $(OPTS) $(CFLAGS) $(LIBS)
++ g++ $(LDFLAGS) -Wall -o $(SASTEROIDS) $(SASTEROIDS_O) $(DEFINES) $(DEBUG) $(OPTS) $(CFLAGS) $(LIBS)
+
+
+ .cpp.o: