summaryrefslogtreecommitdiff
path: root/games-arcade/sdlsasteroids/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /games-arcade/sdlsasteroids/files
reinit the tree, so we can have metadata
Diffstat (limited to 'games-arcade/sdlsasteroids/files')
-rw-r--r--games-arcade/sdlsasteroids/files/sdlsasteroids-3.0.1-gcc43.patch11
-rw-r--r--games-arcade/sdlsasteroids/files/sdlsasteroids-3.0.1-ldflags.patch11
2 files changed, 22 insertions, 0 deletions
diff --git a/games-arcade/sdlsasteroids/files/sdlsasteroids-3.0.1-gcc43.patch b/games-arcade/sdlsasteroids/files/sdlsasteroids-3.0.1-gcc43.patch
new file mode 100644
index 000000000000..5ee05328e897
--- /dev/null
+++ b/games-arcade/sdlsasteroids/files/sdlsasteroids-3.0.1-gcc43.patch
@@ -0,0 +1,11 @@
+--- src/sbitmap.h
++++ src/sbitmap.h
+@@ -36,7 +36,7 @@
+ void LoadImage(char* path);
+ void LoadSurface(SDL_Surface* surface);
+
+- void put(float x, float y, float rotate = 1.0f, float rotate = 1.0f, float layer = 0.0f);
++ void put(float x, float y, float sf = 1.0f, float rotate = 1.0f, float layer = 0.0f);
+ void putA(float x, float y, float layer = 0.0f, float alpha = 1.0f);
+
+ inline float width() const
diff --git a/games-arcade/sdlsasteroids/files/sdlsasteroids-3.0.1-ldflags.patch b/games-arcade/sdlsasteroids/files/sdlsasteroids-3.0.1-ldflags.patch
new file mode 100644
index 000000000000..302c912efe18
--- /dev/null
+++ b/games-arcade/sdlsasteroids/files/sdlsasteroids-3.0.1-ldflags.patch
@@ -0,0 +1,11 @@
+--- src/Makefile.old 2010-09-22 08:44:57.000000000 +0200
++++ src/Makefile 2010-09-22 08:45:43.000000000 +0200
+@@ -26,7 +26,7 @@
+
+
+ $(SASTEROIDS): $(SASTEROIDS_O)
+- g++ -Wall -o $(SASTEROIDS) $(SASTEROIDS_O) $(DEFINES) $(DEBUG) $(OPTS) $(CFLAGS) $(LIBS)
++ g++ $(LDFLAGS) -Wall -o $(SASTEROIDS) $(SASTEROIDS_O) $(DEFINES) $(DEBUG) $(OPTS) $(CFLAGS) $(LIBS)
+
+
+ .cpp.o: