summaryrefslogtreecommitdiff
path: root/games-arcade/sable/sable-1.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-04-28 20:02:04 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-04-28 20:02:04 +0100
commita4e2a46beb5e4858ef27bdedbb0ff6d2ced430ad (patch)
tree852c90a4bf354c30ea66504f70bfab5401fba18d /games-arcade/sable/sable-1.0-r1.ebuild
parent5e8702bcbbed438e6c6cce023e7ef0cc9baa3e02 (diff)
gentoo resync : 28.04.2018
Diffstat (limited to 'games-arcade/sable/sable-1.0-r1.ebuild')
-rw-r--r--games-arcade/sable/sable-1.0-r1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/games-arcade/sable/sable-1.0-r1.ebuild b/games-arcade/sable/sable-1.0-r1.ebuild
new file mode 100644
index 000000000000..9ff9a086c60e
--- /dev/null
+++ b/games-arcade/sable/sable-1.0-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit desktop
+
+DESCRIPTION="A frantic 3D space shooter"
+HOMEPAGE="http://jeuxlibres.net/showgame/sable.html"
+SRC_URI="mirror://gentoo/${P}-src.tgz
+ mirror://gentoo/${PN}.png"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="virtual/opengl
+ media-libs/libsdl[joystick,opengl,sound,video]
+ media-libs/sdl-image[png]
+ media-libs/sdl-mixer"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}"
+
+PATCHES=( "${FILESDIR}"/${P}-gentoo.patch )
+
+src_compile() {
+ emake INSTALL_RESDIR="/usr/share"
+}
+
+src_install() {
+ dobin ${PN}
+ insinto /usr/share/${PN}
+ doins -r models sfx textures
+ einstalldocs
+
+ doicon "${DISTDIR}"/${PN}.png
+ make_desktop_entry ${PN} Sable
+}