summaryrefslogtreecommitdiff
path: root/games-arcade/sable/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-arcade/sable/files
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-arcade/sable/files')
-rw-r--r--games-arcade/sable/files/sable-1.0-gentoo.patch57
1 files changed, 57 insertions, 0 deletions
diff --git a/games-arcade/sable/files/sable-1.0-gentoo.patch b/games-arcade/sable/files/sable-1.0-gentoo.patch
new file mode 100644
index 000000000000..b809936ff964
--- /dev/null
+++ b/games-arcade/sable/files/sable-1.0-gentoo.patch
@@ -0,0 +1,57 @@
+diff -ru sable.orig/src/Makefile sable/src/Makefile
+--- sable.orig/src/Makefile 2006-03-14 00:57:31.000000000 -0500
++++ sable/src/Makefile 2009-01-21 15:15:02.000000000 -0500
+@@ -1,30 +1,10 @@
+-# are we on OSX?
+-ifeq ($(shell uname), Darwin)
+-OSX:=1
+-endif
+-
+-# C options
+-CC = gcc
+-NOOSXFLAGS = -c `sdl-config --cflags` -O2 -Wall -DSABLE_RESOURCEDIR=\"$(INSTALL_RESDIR)/sable/\" -Iinclude $(CFLAGS)
+-ifdef OSX
+-FLAGS = $(NOOSXFLAGS) -D_SABLE_OSX_
+-else
+-FLAGS = $(NOOSXFLAGS)
+-endif
+-
+-# C++ options.
+-CXX = g++
+-CXXFLAGS = $(FLAGS)
++NOOSXFLAGS = -c `sdl-config --cflags` -DSABLE_RESOURCEDIR=\"$(INSTALL_RESDIR)/sable/\" -Iinclude
++
++CFLAGS += $(NOOSXFLAGS)
++CXXFLAGS += $(NOOSXFLAGS)
+
+ # Linker options.
+-LD = g++
+-LDFLAGS =
+-NOOSXLIBS = -lSDL_image -lSDL_mixer
+-ifdef OSX
+-LIBS = `sdl-config --static-libs` $(NOOSXLIBS)
+-else
+-LIBS = `sdl-config --libs` $(NOOSXLIBS) -lGL -lGLU
+-endif
++LIBS = `sdl-config --libs` -lSDL_image -lSDL_mixer -lGL -lGLU
+
+ COBJS = vcontrol/vcontrol.o \
+ bcplrandom.o \
+@@ -35,7 +15,7 @@
+ OBJS = $(COBJS) $(CXXOBJS)
+
+ sable: $(OBJS)
+- $(LD) $(LDFLAGS) -o sable $(OBJS) $(LIBS)
++ $(CXX) $(LDFLAGS) -o sable $(OBJS) $(LIBS)
+
+ clean:
+ rm -f sable *.o vcontrol/*.o svaf/*.o
+@@ -44,7 +24,7 @@
+ find . -name \*.c\* | xargs makedepend -Y. -Iinclude >& /dev/null
+
+ $(COBJS): %.o: %.c
+- $(CC) $(FLAGS) -o $@ $<
++ $(CC) $(CFLAGS) -o $@ $<
+
+ $(CXXOBJS): %.o: %.cpp
+ $(CXX) $(CXXFLAGS) -o $@ $<