summaryrefslogtreecommitdiff
path: root/games-arcade/orthorobot/orthorobot-0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:58:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:58:29 +0100
commit0cf2f20608308acdf3cb922c3736446bbd8f3388 (patch)
tree07815070629c7c11000a7f51ceb8ccbccb49a809 /games-arcade/orthorobot/orthorobot-0-r1.ebuild
parent1798c4aeca70ac8d0a243684d6a798fbc65735f8 (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-arcade/orthorobot/orthorobot-0-r1.ebuild')
-rw-r--r--games-arcade/orthorobot/orthorobot-0-r1.ebuild40
1 files changed, 0 insertions, 40 deletions
diff --git a/games-arcade/orthorobot/orthorobot-0-r1.ebuild b/games-arcade/orthorobot/orthorobot-0-r1.ebuild
deleted file mode 100644
index 69e0533a32ca..000000000000
--- a/games-arcade/orthorobot/orthorobot-0-r1.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit eutils
-
-DESCRIPTION="Perspective based puzzle game, where you flatten the view to move across gaps"
-HOMEPAGE="http://stabyourself.net/orthorobot/"
-SRC_URI="http://stabyourself.net/dl.php?file=${PN}/${PN}-source.zip -> ${P}.zip"
-
-LICENSE="CC-BY-NC-ND-3.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-RDEPEND=">=games-engines/love-0.8.0:0"
-DEPEND="app-arch/unzip"
-
-S="${WORKDIR}"
-
-src_unpack() {
- default
- #it is only one .love file (but with crappy name), so we can use asterisk
- mv *.love "${P}.zip" || die 'mv failed'
- unpack "./${P}.zip"
- rm "${P}.zip" || die 'rm failed'
-}
-
-src_prepare() {
- default
- # fix error on quit
- sed -i -e 's/love.event.push("q")/love.event.push(fadegoal)/' menu.lua || die 'sed failed'
-}
-
-src_install() {
- local dir="/usr/share/love/${PN}"
- insinto "${dir}"
- doins -r .
- make_wrapper "${PN}" "love ${dir}"
- make_desktop_entry "${PN}"
-}