summaryrefslogtreecommitdiff
path: root/games-arcade/nottetris2/nottetris2-1-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-04-28 20:02:04 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-04-28 20:02:04 +0100
commita4e2a46beb5e4858ef27bdedbb0ff6d2ced430ad (patch)
tree852c90a4bf354c30ea66504f70bfab5401fba18d /games-arcade/nottetris2/nottetris2-1-r1.ebuild
parent5e8702bcbbed438e6c6cce023e7ef0cc9baa3e02 (diff)
gentoo resync : 28.04.2018
Diffstat (limited to 'games-arcade/nottetris2/nottetris2-1-r1.ebuild')
-rw-r--r--games-arcade/nottetris2/nottetris2-1-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/games-arcade/nottetris2/nottetris2-1-r1.ebuild b/games-arcade/nottetris2/nottetris2-1-r1.ebuild
new file mode 100644
index 000000000000..47c906bb7ce3
--- /dev/null
+++ b/games-arcade/nottetris2/nottetris2-1-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit eutils
+
+DESCRIPTION="The spiritual successor of the classic Tetris mixed with physics"
+HOMEPAGE="http://stabyourself.net/nottetris2/"
+SRC_URI="http://stabyourself.net/dl.php?file=nottetris2/nottetris2-linux.zip -> ${P}.zip"
+
+LICENSE="CC-BY-NC-SA-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+LVSLOT="0.7"
+RDEPEND=">=games-engines/love-0.7.2:${LVSLOT}
+ media-libs/devil[png]
+"
+DEPEND="app-arch/unzip"
+
+S="${WORKDIR}"
+
+src_install() {
+ local dir=/usr/share/love/${PN}
+
+ exeinto "${dir}"
+ newexe "Not Tetris 2.love" ${PN}.love
+
+ newdoc "Not Readme.txt" README
+
+ make_wrapper ${PN} "love-${LVSLOT} ${PN}.love" "${dir}"
+ make_desktop_entry ${PN}
+}