summaryrefslogtreecommitdiff
path: root/games-arcade/mrrescue/mrrescue-1.02b-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-21 19:00:36 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-21 19:00:36 +0100
commit491c3b190bc8dfebeb156c06938f76034140b65f (patch)
tree84527f8c75d6aa03bf4b2ae2531ccf7f263aa8ca /games-arcade/mrrescue/mrrescue-1.02b-r2.ebuild
parent520a5b56dff7c24c9d42eafec142cb78b44f8e3e (diff)
gentoo resync : 21.07.2018
Diffstat (limited to 'games-arcade/mrrescue/mrrescue-1.02b-r2.ebuild')
-rw-r--r--games-arcade/mrrescue/mrrescue-1.02b-r2.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/games-arcade/mrrescue/mrrescue-1.02b-r2.ebuild b/games-arcade/mrrescue/mrrescue-1.02b-r2.ebuild
new file mode 100644
index 000000000000..c33e2ef05b0d
--- /dev/null
+++ b/games-arcade/mrrescue/mrrescue-1.02b-r2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit eutils gnome2-utils
+
+DESCRIPTION="Arcade 2d action game based around evacuating civilians from burning buildings"
+HOMEPAGE="http://tangramgames.dk/games/mrrescue/"
+SRC_URI="https://github.com/SimonLarsen/mrrescue/releases/download/v${PV}/${P}-love.zip
+ https://dev.gentoo.org/~hasufell/distfiles/${PN}.png"
+
+LICENSE="CC-BY-SA-3.0 MIT ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+LVSLOT="0.8"
+RDEPEND="games-engines/love:${LVSLOT}"
+DEPEND="app-arch/unzip"
+
+S="${WORKDIR}/${P}-love"
+
+src_install() {
+ local dir=/usr/share/love/${PN}
+
+ exeinto "${dir}"
+ doexe ${PN}.love
+
+ einstalldocs
+
+ doicon -s 64 "${DISTDIR}"/${PN}.png
+ make_wrapper ${PN} "love-${LVSLOT} ${PN}.love" "${dir}"
+ make_desktop_entry ${PN}
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}