summaryrefslogtreecommitdiff
path: root/games-arcade/methane/methane-1.5.1-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /games-arcade/methane/methane-1.5.1-r1.ebuild
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'games-arcade/methane/methane-1.5.1-r1.ebuild')
-rw-r--r--games-arcade/methane/methane-1.5.1-r1.ebuild28
1 files changed, 16 insertions, 12 deletions
diff --git a/games-arcade/methane/methane-1.5.1-r1.ebuild b/games-arcade/methane/methane-1.5.1-r1.ebuild
index d26feb258d71..7d0a032b4ccc 100644
--- a/games-arcade/methane/methane-1.5.1-r1.ebuild
+++ b/games-arcade/methane/methane-1.5.1-r1.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit desktop
+
+inherit desktop toolchain-funcs
DESCRIPTION="Port from an old amiga game"
HOMEPAGE="http://methane.sourceforge.net/"
@@ -11,34 +12,37 @@ SRC_URI="mirror://sourceforge/${PN}/${P}.tgz"
LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
RDEPEND="dev-games/clanlib:2.3[opengl,mikmod]"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
-"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-gentoo.patch
+ # From Fedora
+ "${FILESDIR}"/${P}-gcc5.patch
+ "${FILESDIR}"/${P}-fullscreen.patch
+)
src_prepare() {
default
- eapply "${FILESDIR}"/${P}-gentoo.patch
-
- # From Fedora
- eapply "${FILESDIR}"/${P}-gcc5.patch
- eapply "${FILESDIR}"/${P}-fullscreen.patch
-
sed -i \
-e "s:@GENTOO_DATADIR@:/usr/share:" \
sources/target.cpp || die
+ tc-export CXX PKG_CONFIG
+
# fix weird parallel make issue wrt #450422
mkdir build || die
}
src_install() {
dobin methane
+
insinto /usr/share/${PN}
doins resources/*
+
newicon docs/puff.gif ${PN}.gif
make_desktop_entry ${PN} "Super Methane Brothers" /usr/share/pixmaps/${PN}.gif
HTML_DOCS="docs/*" dodoc authors.txt history.txt readme.txt