summaryrefslogtreecommitdiff
path: root/games-arcade/methane/methane-1.5.1-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-08-12 06:32:46 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-08-12 06:32:46 +0100
commit28e3d252dc8ac8a5635206dfefe1cfe05058d1db (patch)
treee75bce604750fb72e53ed3684059e2e5d2094509 /games-arcade/methane/methane-1.5.1-r1.ebuild
parentf625b9919a60a30f1bd860f7d1b2eac183ced593 (diff)
gentoo resync : 12.08.2018
Diffstat (limited to 'games-arcade/methane/methane-1.5.1-r1.ebuild')
-rw-r--r--games-arcade/methane/methane-1.5.1-r1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/games-arcade/methane/methane-1.5.1-r1.ebuild b/games-arcade/methane/methane-1.5.1-r1.ebuild
new file mode 100644
index 000000000000..d26feb258d71
--- /dev/null
+++ b/games-arcade/methane/methane-1.5.1-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit desktop
+
+DESCRIPTION="Port from an old amiga game"
+HOMEPAGE="http://methane.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tgz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-games/clanlib:2.3[opengl,mikmod]"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ default
+
+ eapply "${FILESDIR}"/${P}-gentoo.patch
+
+ # From Fedora
+ eapply "${FILESDIR}"/${P}-gcc5.patch
+ eapply "${FILESDIR}"/${P}-fullscreen.patch
+
+ sed -i \
+ -e "s:@GENTOO_DATADIR@:/usr/share:" \
+ sources/target.cpp || die
+
+ # fix weird parallel make issue wrt #450422
+ mkdir build || die
+}
+
+src_install() {
+ dobin methane
+ insinto /usr/share/${PN}
+ doins resources/*
+ newicon docs/puff.gif ${PN}.gif
+ make_desktop_entry ${PN} "Super Methane Brothers" /usr/share/pixmaps/${PN}.gif
+ HTML_DOCS="docs/*" dodoc authors.txt history.txt readme.txt
+}