summaryrefslogtreecommitdiff
path: root/games-arcade/methane/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /games-arcade/methane/files
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'games-arcade/methane/files')
-rw-r--r--games-arcade/methane/files/methane-1.5.1-gentoo.patch16
1 files changed, 8 insertions, 8 deletions
diff --git a/games-arcade/methane/files/methane-1.5.1-gentoo.patch b/games-arcade/methane/files/methane-1.5.1-gentoo.patch
index 6d72a2ca7ed5..26a1b438c8a8 100644
--- a/games-arcade/methane/files/methane-1.5.1-gentoo.patch
+++ b/games-arcade/methane/files/methane-1.5.1-gentoo.patch
@@ -1,10 +1,10 @@
---- a/Makefile.old 2012-11-26 18:58:48.201837870 +0100
-+++ b/Makefile 2012-11-27 12:30:16.038998128 +0100
+--- a/Makefile
++++ b/Makefile
@@ -1,5 +1,5 @@
-METHANE_FLAGS = -DENABLE_SOUND `pkg-config --cflags clanCore-2.2 clanDisplay-2.2 clanApp-2.2 clanGL-2.2 clanGL1-2.2 clanSWRender-2.2 clanSound-2.2 clanMikMod-2.2`
-METHANE_LIBS = `pkg-config --libs clanCore-2.2 clanDisplay-2.2 clanApp-2.2 clanGL-2.2 clanGL1-2.2 clanSWRender-2.2 clanSound-2.2 clanMikMod-2.2`
-+METHANE_FLAGS = -DENABLE_SOUND `pkg-config --cflags clanCore-2.3 clanDisplay-2.3 clanApp-2.3 clanGL-2.3 clanGL1-2.3 clanSWRender-2.3 clanSound-2.3 clanMikMod-2.3`
-+METHANE_LIBS = `pkg-config --libs clanCore-2.3 clanDisplay-2.3 clanApp-2.3 clanGL-2.3 clanGL1-2.3 clanSWRender-2.3 clanSound-2.3 clanMikMod-2.3`
++METHANE_FLAGS = -DENABLE_SOUND `${PKG_CONFIG} --cflags clanCore-2.3 clanDisplay-2.3 clanApp-2.3 clanGL-2.3 clanGL1-2.3 clanSWRender-2.3 clanSound-2.3 clanMikMod-2.3`
++METHANE_LIBS = `${PKG_CONFIG} --libs clanCore-2.3 clanDisplay-2.3 clanApp-2.3 clanGL-2.3 clanGL1-2.3 clanSWRender-2.3 clanSound-2.3 clanMikMod-2.3`
OBJF = build/game.o build/baddie.o build/methane.o build/target.o build/maps.o build/gfxoff.o build/mapdata.o build/objlist.o build/doc.o build/bitdraw.o build/global.o build/suck.o build/power.o build/goodie.o build/bititem.o build/player.o build/weapon.o build/bitgroup.o build/boss.o build/sound.o build/gasobj.o build/misc.o
@@ -25,8 +25,8 @@
+ $(CXX) ${CXXFLAGS} ${METHANE_FLAGS} -c $< -o $@
---- a/sources/methane.cpp.old 2012-11-27 13:49:22.993003266 +0100
-+++ b/sources/methane.cpp 2012-11-27 17:37:23.051913777 +0100
+--- a/sources/methane.cpp
++++ b/sources/methane.cpp
@@ -80,15 +80,15 @@
return 0;
}
@@ -49,8 +49,8 @@
}
// Set the video mode
---- a/sources/target.cpp.old 2012-11-28 21:34:32.666878913 +0100
-+++ b/sources/target.cpp 2012-11-28 21:35:16.371247221 +0100
+--- a/sources/target.cpp
++++ b/sources/target.cpp
@@ -132,7 +132,7 @@
CL_GraphicContext gc = m_pWindow->get_gc();