summaryrefslogtreecommitdiff
path: root/games-arcade/marbleblast-demo
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /games-arcade/marbleblast-demo
reinit the tree, so we can have metadata
Diffstat (limited to 'games-arcade/marbleblast-demo')
-rw-r--r--games-arcade/marbleblast-demo/Manifest5
-rw-r--r--games-arcade/marbleblast-demo/marbleblast-demo-1.3.ebuild34
-rw-r--r--games-arcade/marbleblast-demo/metadata.xml31
3 files changed, 70 insertions, 0 deletions
diff --git a/games-arcade/marbleblast-demo/Manifest b/games-arcade/marbleblast-demo/Manifest
new file mode 100644
index 000000000000..d99009a15f95
--- /dev/null
+++ b/games-arcade/marbleblast-demo/Manifest
@@ -0,0 +1,5 @@
+DIST MarbleBlastDemo-1.3.sh.bin 10800892 SHA256 84d547df84ce2fdc82eb0316ff737d4ae1b1bf50ce4541870847b51de6bfd1a4 SHA512 24bd5f03c8868ab83e2bcfe27ab60f86727e972f04cafe4d5ff940a77adf4a362c3de1b0391b5763aed8dc946af7b769da60654b2ea53133521b200a99ebdde8 WHIRLPOOL de4288f9eb5f4a1421bcbed54b157eafd00b3076756b3ecb306df96bf1636745ee06be1738fa0b86df0148e0496cd0eea2e89062a5c2efbc14f02fb2d909f872
+EBUILD marbleblast-demo-1.3.ebuild 817 SHA256 aa5d5b54b596ead025e42ff4a8a4f307c4a7dd14f90de1680cad69fb1dec860c SHA512 23e90f6e5edd3477db492f3219417639b3c27ef0c3f2dee6ff5fe1c86bcc86ccd7a48577d25debe660239f1bd05d951276627da408da24a58fe63258e57b99bd WHIRLPOOL acfe146394d95cd50ede213f05d4354fbc74be3ce6beea12084264418ae9f33383b017da905b82ca69ce31abe9c6acbb5d7d74b86c3c99af387c9f0f20e03919
+MISC ChangeLog 2454 SHA256 fdc240d52e185198946c7b4fee9cce3e0571dcde8573756728410472099836b4 SHA512 dc7a72b4890c06f55d869b781f2eec58b556f0866becccba4c06ac803d3efd6fff3ee2429bba6dd81250e7d2b26a5cfc56ca4ae291555d39fa606b181b6057a6 WHIRLPOOL cbeb646c2752afe48a8f2b25127ad19df2f1d36993434afb1519bb5aaccc41e46526d82aecd78c1964eb2a0c9082c33025f74a3c754e5982ed5088cfe2607242
+MISC ChangeLog-2015 1815 SHA256 4b3f0f002fe1b2b5371d223c485fe03bf64ddf801be7dce0cb80016f723c2a54 SHA512 4c880877c58c7a56b3190b1b2cd5987d97dba6296b6f4a8ed7872d69e1db11fd09a9506911104ce7632ec965a176fdbaae2d469bba38477989f687018d274e7a WHIRLPOOL dc30e8898057d76987ceb97ee79ec67166a103684fec5a653ecdd1115c775038236463206af21279475dccaecff043f47f7672e785a3919afe19a94550d675bb
+MISC metadata.xml 1469 SHA256 addcbc44d1080b3f7bbc22b24fb30abb8bf3bbf43617626563ebe3c39f372c1a SHA512 c11947aebdc32a03efd9645466df5e946a386d262a6e529e289cdc213e93d993ff67300d9d96b69af647a84947777dc6f90db9a0a5568d02ba81689ff90b2b45 WHIRLPOOL b6f91e888948e6a7cbc036eeb4d37e61323691519daff04dce17d7a3e6ef4827be1e4a646975334ec69500aed081bed83cacaefc59c8f38f09e1b1acfd6fc692
diff --git a/games-arcade/marbleblast-demo/marbleblast-demo-1.3.ebuild b/games-arcade/marbleblast-demo/marbleblast-demo-1.3.ebuild
new file mode 100644
index 000000000000..cdce620fd6dc
--- /dev/null
+++ b/games-arcade/marbleblast-demo/marbleblast-demo-1.3.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+EAPI=5
+inherit unpacker games
+
+DESCRIPTION="race marbles through crazy stages"
+HOMEPAGE="http://www.garagegames.com/pg/product/view.php?id=3"
+SRC_URI="ftp://ggdev-1.homelan.com/marbleblast/MarbleBlastDemo-${PV}.sh.bin"
+
+LICENSE="MARBLEBLAST"
+SLOT="0"
+KEYWORDS="-* ~amd64 x86"
+IUSE=""
+RESTRICT="strip"
+
+S=${WORKDIR}
+
+dir=${GAMES_PREFIX_OPT}/${PN}
+QA_PREBUILT="${dir:1}/marbleblastdemo.bin
+ ${dir:1}/lib/lib*"
+
+src_install() {
+ dodir "${dir}" "${GAMES_BINDIR}"
+
+ tar -zxf MarbleBlast.tar.gz -C "${D}/${dir}" || die "extracting MarbleBlast.tar.gz"
+
+ exeinto "${dir}"
+ doexe bin/Linux/x86/marbleblastdemo
+ dosym "${dir}"/marbleblastdemo "${GAMES_BINDIR}"/marbleblast-demo
+
+ dodoc README_DEMO.txt
+
+ prepgamesdirs
+}
diff --git a/games-arcade/marbleblast-demo/metadata.xml b/games-arcade/marbleblast-demo/metadata.xml
new file mode 100644
index 000000000000..581d9cab5924
--- /dev/null
+++ b/games-arcade/marbleblast-demo/metadata.xml
@@ -0,0 +1,31 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+</maintainer>
+<longdescription>
+Marble Blast is an arcade action game with simple yet addictive gameplay,
+suitable for players of any age. In the rich cartoon landscape of Marble
+Blast, players will race their marbles through moving platforms, dangerous
+hazards, sparkling treasures and power up enhancements in an effort to
+complete each course in record time.
+
+Marble Blast introduces new players to the game with a set of
+progressively more difficult beginner training levels, each designed to
+showcase a power up or game hazard. The hazards players will face in
+Marble Blast include powerful fans, whirling tornados, land mines,
+pinball-style bumpers, narrow catwalks, moving pistons, dizzying chasms,
+and more.
+
+To get past these obstacles, players can find and use five different
+ability enhancing power ups - the SuperSpeed, SuperJump, SuperBounce,
+Shock Asbsorber and Gyrocopter. Some levels contain gravity modifiers,
+which allow the player to change the direction of gravity.
+
+Marble Blast comes with 72 whimsical and challenging levels, as well as
+the ability for advanced players to craft and share their own levels.
+Marble Blast is sure to provide many hours of fun for the whole family.
+</longdescription>
+</pkgmetadata>