summaryrefslogtreecommitdiff
path: root/games-arcade/lbreakout/lbreakout-010315-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-arcade/lbreakout/lbreakout-010315-r1.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-arcade/lbreakout/lbreakout-010315-r1.ebuild')
-rw-r--r--games-arcade/lbreakout/lbreakout-010315-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/games-arcade/lbreakout/lbreakout-010315-r1.ebuild b/games-arcade/lbreakout/lbreakout-010315-r1.ebuild
new file mode 100644
index 000000000000..4a465d929cfc
--- /dev/null
+++ b/games-arcade/lbreakout/lbreakout-010315-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Breakout clone written with the SDL library"
+HOMEPAGE="http://lgames.sourceforge.net/LBreakout/"
+SRC_URI="mirror://sourceforge/lgames/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=media-libs/libsdl-1.1.5"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+ sed -i \
+ -e '/^sdir=/s:$datadir/games:$datadir:' \
+ -e '/^hdir=/s:/var/lib/games:$localstatedir:' \
+ configure \
+ || die "sed failed"
+}
+
+src_install() {
+ HTML_DOCS="lbreakout/manual/*"
+ default
+}