summaryrefslogtreecommitdiff
path: root/games-arcade/holotz-castle/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-arcade/holotz-castle/files
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-arcade/holotz-castle/files')
-rw-r--r--games-arcade/holotz-castle/files/holotz-castle-1.3.14-build.patch71
-rw-r--r--games-arcade/holotz-castle/files/holotz-castle-1.3.14-gcc44.patch11
-rw-r--r--games-arcade/holotz-castle/files/holotz-castle-1.3.14-underlink.patch11
3 files changed, 93 insertions, 0 deletions
diff --git a/games-arcade/holotz-castle/files/holotz-castle-1.3.14-build.patch b/games-arcade/holotz-castle/files/holotz-castle-1.3.14-build.patch
new file mode 100644
index 000000000000..cdf814546e1d
--- /dev/null
+++ b/games-arcade/holotz-castle/files/holotz-castle-1.3.14-build.patch
@@ -0,0 +1,71 @@
+--- a/JLib/Makefile
++++ b/JLib/Makefile
+@@ -19,7 +19,7 @@
+ endif
+
+ # Define -D_JLIB_DEBUG to debug JLib. Compile the app to debug also with this flag
+-CFLAGS=-I. -I/usr/local/include/SDL -O3 -ffast-math -fPIC -Wall -Wshadow `$(SDL_CONFIG) --cflags`
++CXXFLAGS+=-I. -Wall -Wshadow `$(SDL_CONFIG) --cflags`
+
+ # Sample LDFLAGS for applications
+ # LDFLAGS=-L. -ffast-math -lSDL_image -lSDL_ttf -lSDL_mixer `$(SDL_CONFIG) --libs`
+@@ -28,15 +28,14 @@
+
+ # JLib
+ libJLib: $(JLIB_OBJS)
+- g++-4.1 -shared -L/usr/lib -fPIC -o $@.so $? \
+- && ar rvus $@.a $? \
++ $(AR) rvus $@.a $?
+
+ $(GRAPHICS)/%.o: $(GRAPHICS)/%.cpp
+- g++-4.1 $(CFLAGS) -c -o $@ $<
++ $(CXX) $(CXXFLAGS) -c -o $@ $<
+ $(UTIL)/%.o: $(UTIL)/%.cpp
+- g++-4.1 $(CFLAGS) -c -o $@ $<
++ $(CXX) $(CXXFLAGS) -c -o $@ $<
+ $(MATH)/%.o: $(MATH)/%.cpp
+- g++-4.1 $(CFLAGS) -c -o $@ $<
++ $(CXX) $(CXXFLAGS) -c -o $@ $<
+
+ .PHONY: install
+ install:
+--- a/src/Makefile
++++ b/src/Makefile
+@@ -30,7 +30,7 @@
+
+ DEFINES = -DHC_DATA_DIR=\"$(HC_DATA)\" -DHCED_DATA_DIR=\"$(HCED_DATA)\"
+
+-all: JLib HC HCed
++all: HC HCed
+
+ HC_OBJ_MAIN=HolotzCastle.o
+ HC_OBJS=HCUtil.o HCTimer.o HCLoadSaveSlot.o HCPlaylist.o HCPreferences.o HCTheme.o HCText.o \
+@@ -42,23 +42,23 @@
+
+ # Definir -D_JLIB_DEBUG para debug con JLib. Ponerlo también en el Makefile de JLib.
+ # Define -D_JLIB_DEBUG for JLib debug mode. Put it also in JLib's Makefile.
+-CFLAGS=-fno-strict-aliasing -I. -I../JLib `$(SDL_CONFIG) --cflags` -I/usr/local/include/ -I/usr/local/include/SDL -O3 -Wall -Werror -Wshadow $(CPU_OPTS) -ffast-math -c
+-LDFLAGS=-L. -ffast-math -lSDL_image -lSDL_ttf -lSDL_mixer `$(SDL_CONFIG) --libs`
++CXXFLAGS+=-fno-strict-aliasing -I. -I../JLib `$(SDL_CONFIG) --cflags` -Wall -Wshadow
++LDLIBS=-L. -lSDL_image -lSDL_ttf -lSDL_mixer `$(SDL_CONFIG) --libs`
+
+
+ JLib:
+ $(MAKE) -C ../JLib;
+
+ %.o: %.cpp %.h
+- g++ $(CFLAGS) $(DEFINES) $< -o $@
++ $(CXX) -c $(CXXFLAGS) $(DEFINES) $< -o $@
+
+ HC: $(HC_OBJS) $(HC_OBJ_MAIN) ../JLib/libJLib.a
+- g++ $(LDFLAGS) $? -o $@;\
++ $(CXX) $(CXXFLAGS) $(LDFLAGS) -o $@ $? $(LDLIBS);\
+ mv HC ../holotz-castle
+
+ # HCed (Holotz's Castle editor).
+ HCed: $(HC_OBJS) $(HCED_OBJ_MAIN) ../JLib/libJLib.a
+- g++ $(LDFLAGS) $? -o $@;\
++ $(CXX) $(CXXFLAGS) $(LDFLAGS) -o $@ $? $(LDLIBS);\
+ mv HCed ../holotz-castle-editor
+
+ install:
diff --git a/games-arcade/holotz-castle/files/holotz-castle-1.3.14-gcc44.patch b/games-arcade/holotz-castle/files/holotz-castle-1.3.14-gcc44.patch
new file mode 100644
index 000000000000..ecf9d5c32de9
--- /dev/null
+++ b/games-arcade/holotz-castle/files/holotz-castle-1.3.14-gcc44.patch
@@ -0,0 +1,11 @@
+--- a/JLib/JLib/Util/JFS.cpp
++++ b/JLib/JLib/Util/JFS.cpp
+@@ -887,7 +887,7 @@
+
+ // Si es un directorio lo importa recursivamente
+ struct dirent64 **namelist;
+- n = scandir64(filename, &namelist, 0, alphasort);
++ n = scandir64(filename, &namelist, 0, alphasort64);
+
+ if (n < 0)
+ {
diff --git a/games-arcade/holotz-castle/files/holotz-castle-1.3.14-underlink.patch b/games-arcade/holotz-castle/files/holotz-castle-1.3.14-underlink.patch
new file mode 100644
index 000000000000..efcf379fb129
--- /dev/null
+++ b/games-arcade/holotz-castle/files/holotz-castle-1.3.14-underlink.patch
@@ -0,0 +1,11 @@
+--- a/src/Makefile.old 2011-06-22 06:09:53.195025702 +0200
++++ b/src/Makefile 2011-06-22 06:10:54.774927134 +0200
+@@ -43,7 +43,7 @@
+ # Definir -D_JLIB_DEBUG para debug con JLib. Ponerlo también en el Makefile de JLib.
+ # Define -D_JLIB_DEBUG for JLib debug mode. Put it also in JLib's Makefile.
+ CXXFLAGS+=-fno-strict-aliasing -I. -I../JLib `$(SDL_CONFIG) --cflags` -Wall -Wshadow
+-LDLIBS=-L. -lSDL_image -lSDL_ttf -lSDL_mixer `$(SDL_CONFIG) --libs`
++LDLIBS=-L. -lSDL_image -lSDL_ttf -lSDL_mixer `$(SDL_CONFIG) --libs` -lm -lz
+
+
+ JLib: