summaryrefslogtreecommitdiff
path: root/games-arcade/gav/gav-0.9.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /games-arcade/gav/gav-0.9.0-r1.ebuild
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'games-arcade/gav/gav-0.9.0-r1.ebuild')
-rw-r--r--games-arcade/gav/gav-0.9.0-r1.ebuild13
1 files changed, 10 insertions, 3 deletions
diff --git a/games-arcade/gav/gav-0.9.0-r1.ebuild b/games-arcade/gav/gav-0.9.0-r1.ebuild
index 06d00b3ebba1..babd49793332 100644
--- a/games-arcade/gav/gav-0.9.0-r1.ebuild
+++ b/games-arcade/gav/gav-0.9.0-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit desktop toolchain-funcs
+inherit toolchain-funcs
DESCRIPTION="GPL Arcade Volleyball"
HOMEPAGE="http://gav.sourceforge.net/"
@@ -44,12 +44,19 @@ src_prepare() {
# Now, move the additional themes in the proper directory
mv ../{fabeach,florindo,inverted,naive,unnamed,yisus,yisus2} themes || die
- # no reason to have executable bit set on themes
+ # No reason to have executable bit set on themes
find themes -type f -exec chmod a-x '{}' \; || die
+
+ # Respect LD, bug #779976
+ sed -i -e 's/LD = ld/LD ?= ld/' CommonHeader || die
+ sed -i -e 's/$(LD)/& $(LDFLAGS)/' */Makefile || die
}
src_configure() {
tc-export CXX
+
+ # Nobody _really_ sets LD. Tell the compiler what to do instead.
+ export LD="${CXX}"
}
src_compile() {