summaryrefslogtreecommitdiff
path: root/games-arcade/gav/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-arcade/gav/files
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-arcade/gav/files')
-rw-r--r--games-arcade/gav/files/gav-0.9.0-gcc43.patch10
-rw-r--r--games-arcade/gav/files/gav-0.9.0-ldflags.patch26
2 files changed, 36 insertions, 0 deletions
diff --git a/games-arcade/gav/files/gav-0.9.0-gcc43.patch b/games-arcade/gav/files/gav-0.9.0-gcc43.patch
new file mode 100644
index 000000000000..c9b8a6e588bf
--- /dev/null
+++ b/games-arcade/gav/files/gav-0.9.0-gcc43.patch
@@ -0,0 +1,10 @@
+--- a/Configuration.cpp
++++ b/Configuration.cpp
+@@ -25,6 +25,7 @@
+ #include <stdlib.h>
+ #include <string>
+ #include <iostream>
++#include <cstring>
+ #include "Configuration.h"
+ #include "ControlsArray.h"
+
diff --git a/games-arcade/gav/files/gav-0.9.0-ldflags.patch b/games-arcade/gav/files/gav-0.9.0-ldflags.patch
new file mode 100644
index 000000000000..dd49e6161660
--- /dev/null
+++ b/games-arcade/gav/files/gav-0.9.0-ldflags.patch
@@ -0,0 +1,26 @@
+--- a/CommonHeader.old 2010-10-12 13:08:23.000000000 +0200
++++ b/CommonHeader 2010-10-12 13:08:48.000000000 +0200
+@@ -31,9 +31,9 @@
+ endif
+
+ ifdef NET
+-LDFLAGS= `sdl-config --libs` -lSDL_image -lSDL_net -lm
++LDLIBS= `sdl-config --libs` -lSDL_image -lSDL_net -lm
+ else
+-LDFLAGS= `sdl-config --libs` -lSDL_image -lm
++LDLIBS= `sdl-config --libs` -lSDL_image -lm
+ endif
+
+ SRCS = $(wildcard *.cpp)
+--- a/Makefile.Linux.old 2010-10-12 14:36:47.000000000 +0200
++++ b/Makefile.Linux 2010-10-12 14:37:02.000000000 +0200
+@@ -38,8 +38,7 @@
+ $(MAKE) -C $(@D:%_module.o=%)
+
+ gav: $(ALL_OBJ) $(OFILES)
+- $(CXX) -o gav $(OFILES) $(ALL_OBJ) $(LDFLAGS)
+- strip gav
++ $(CXX) $(LDFLAGS) -o gav $(OFILES) $(ALL_OBJ) $(LDLIBS)
+
+ clean:
+ for i in $(SUBDIRS) ; do \