summaryrefslogtreecommitdiff
path: root/games-arcade/fishsupper/fishsupper-0.1.6-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-04-19 14:14:48 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-04-19 14:14:48 +0100
commit5cfef3c94cd7e82136c69a0322f5ba21f7e64632 (patch)
tree8f255dfacbacb657e3ac3654d01c1e11e651c066 /games-arcade/fishsupper/fishsupper-0.1.6-r1.ebuild
parent8aebb228036d5e2863b7eaa6e319ab41c1669269 (diff)
gentoo resync : 19.04.2018
Diffstat (limited to 'games-arcade/fishsupper/fishsupper-0.1.6-r1.ebuild')
-rw-r--r--games-arcade/fishsupper/fishsupper-0.1.6-r1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/games-arcade/fishsupper/fishsupper-0.1.6-r1.ebuild b/games-arcade/fishsupper/fishsupper-0.1.6-r1.ebuild
new file mode 100644
index 000000000000..e73b4a0b1d7d
--- /dev/null
+++ b/games-arcade/fishsupper/fishsupper-0.1.6-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools desktop
+
+DESCRIPTION="A simple arcade/puzzle game, loosely based on the retro classic Frogger"
+HOMEPAGE="https://sourceforge.net/projects/fishsupper/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="CC-BY-SA-2.5 GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ media-libs/libsdl[sound,video,opengl,X]
+ media-libs/sdl-image[png]
+ media-libs/sdl-mixer[wav]
+ virtual/opengl
+"
+DEPEND="${RDEPEND}
+ dev-libs/boost
+"
+
+src_prepare() {
+ default
+ eapply "${FILESDIR}"/${P}-ovflfix.patch \
+ "${FILESDIR}"/${P}-asneeded.patch \
+ "${FILESDIR}"/${P}-gcc6.patch
+ eautoreconf
+}
+
+src_install() {
+ default
+ newicon data/images/fs_sprite_042.png ${PN}.png
+ make_desktop_entry ${PN} "Fish Supper"
+}