summaryrefslogtreecommitdiff
path: root/games-arcade/excido/excido-0.1.5c-r3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-04-19 14:14:48 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-04-19 14:14:48 +0100
commit5cfef3c94cd7e82136c69a0322f5ba21f7e64632 (patch)
tree8f255dfacbacb657e3ac3654d01c1e11e651c066 /games-arcade/excido/excido-0.1.5c-r3.ebuild
parent8aebb228036d5e2863b7eaa6e319ab41c1669269 (diff)
gentoo resync : 19.04.2018
Diffstat (limited to 'games-arcade/excido/excido-0.1.5c-r3.ebuild')
-rw-r--r--games-arcade/excido/excido-0.1.5c-r3.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/games-arcade/excido/excido-0.1.5c-r3.ebuild b/games-arcade/excido/excido-0.1.5c-r3.ebuild
new file mode 100644
index 000000000000..cea4558b0b61
--- /dev/null
+++ b/games-arcade/excido/excido-0.1.5c-r3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit desktop
+
+DESCRIPTION="A fast paced action game"
+HOMEPAGE="http://icculus.org/excido/"
+SRC_URI="http://icculus.org/excido/${P}-src.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-games/physfs
+ media-libs/libsdl[opengl]
+ media-libs/sdl-mixer
+ media-libs/sdl-ttf
+ media-libs/sdl-image[png]
+ media-libs/openal
+ media-libs/freealut"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-freealut.patch
+ "${FILESDIR}"/${P}-build.patch
+)
+
+src_compile() {
+ emake DATADIR=/usr/share/${PN}/
+}
+
+src_install() {
+ dobin ${PN}
+ insinto /usr/share/${PN}
+ doins data/*
+ dodoc BUGS CHANGELOG HACKING README TODO \
+ keyguide.txt data/CREDITS data/*.txt
+}