summaryrefslogtreecommitdiff
path: root/games-arcade/circuslinux
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /games-arcade/circuslinux
reinit the tree, so we can have metadata
Diffstat (limited to 'games-arcade/circuslinux')
-rw-r--r--games-arcade/circuslinux/Manifest5
-rw-r--r--games-arcade/circuslinux/circuslinux-1.0.3.ebuild38
-rw-r--r--games-arcade/circuslinux/metadata.xml8
3 files changed, 51 insertions, 0 deletions
diff --git a/games-arcade/circuslinux/Manifest b/games-arcade/circuslinux/Manifest
new file mode 100644
index 000000000000..fe0fba43b651
--- /dev/null
+++ b/games-arcade/circuslinux/Manifest
@@ -0,0 +1,5 @@
+DIST circuslinux-1.0.3.tar.gz 1253839 SHA256 bf9550ebd598a9e7d93a20d80ff466475122f8b023314bb1e07c31e8c608ce8a SHA512 292bcaad39342ad69862f1add36b11505ca5f2601637a8db6fad438c5a4b32d7801bc7e6c08b903b0fb8bf68dcb3ec8d968fb913cde65941b9b9ac64b5a5266f WHIRLPOOL 735d87965107297f139971bcdcb5bb10bd996f5a355062c207f656c65089b305eb96bfc1c76a9a1c61a9a1a0d092ab386b8fc87b359470e8eec58fe9925fe4a3
+EBUILD circuslinux-1.0.3.ebuild 822 SHA256 898b6fb63401f4093e6db2a4a421fc78ea155156e03d8ceb194cc9a695f5068f SHA512 0bb65a51f97c9f254c880411ad7776dfdb14e6110aa71115983a53096f27dae9593f8bb92f953aba9b2ec00419137d5feed2e8c9bd8e3b4a9fcd70cbcc334dd6 WHIRLPOOL 5ee18b02558d25c1983ca78c796dcaad13425d73285c3c1092c1d368f7c1bf4e014259264698eb4a14d4fd9ed3c7450a3ef3bf3bdb418ba550dde9c0846d9ccf
+MISC ChangeLog 2443 SHA256 8dd00540d17dccc0fa20ea93a02171e91e90c2d9bc78e23427a044e1110b2df5 SHA512 2d0067780893ba4a317304cea2740962b1812e17bbf9d25adfa28a4a25870aa9756845d59d29131387b207f1757438288f726efa408cdf008112a574ccb32816 WHIRLPOOL fb6e5901f5806ed65dd170fcb408185229b2a594a0e522b9756f76a0b56b6d7cc974ab1fc2e2293acfda1be0ec5e3d082bed06b1745cb9d6ae9403f27479881a
+MISC ChangeLog-2015 2677 SHA256 d4a1063f964ee31cb92e6dd6b52d0ffa844a66b854f9f0489ca37c9c3e42c629 SHA512 c3be448175c304c3070883b9747895fc5b0608c10e1280c14e1366044814080f348e40dc2b151466900b1a3a0bec8256421aa78f68f683ae3ab319e38f8c7547 WHIRLPOOL e74d8ed287c36eda52dcdbf84e539d13bcbfe5d4ee10d2cb84ff325c25deade9dc9e73607a8544a2c2d64c5b5965f4c58e780865e57cdaeda919d647bf50d0ed
+MISC metadata.xml 249 SHA256 943b9ce0cd072229b43569ab668dd7ec741d9dfefd942c8921dabd4490b27b0c SHA512 895577c3a805c40581da03057b94e3f28f05f23012bf350c1e3575847d1a0fe40bb044a46f909012a200d991a400f6389358a60e9c2b5bef0da01fb26f846118 WHIRLPOOL b10e21575c78e201a652c8582cd16e3f7c86b13dd20a30f4cea44066fb139440b3c186147dbaae83478f11a20b6f457a99c8b29ee1239a4caaa21eee01250088
diff --git a/games-arcade/circuslinux/circuslinux-1.0.3.ebuild b/games-arcade/circuslinux/circuslinux-1.0.3.ebuild
new file mode 100644
index 000000000000..042fa47ffc38
--- /dev/null
+++ b/games-arcade/circuslinux/circuslinux-1.0.3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit eutils games
+
+DESCRIPTION="clone of the Atari 2600 game \"Circus Atari\""
+SRC_URI="ftp://ftp.sonic.net/pub/users/nbs/unix/x/circus-linux/${P}.tar.gz"
+HOMEPAGE="http://www.newbreedsoftware.com/circus-linux/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 x86"
+IUSE=""
+
+DEPEND="media-libs/libsdl
+ media-libs/sdl-image[png]
+ media-libs/sdl-mixer[mod]"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ sed -i \
+ -e "/^install-data-am/d" \
+ Makefile.in \
+ || die
+ sed -i \
+ -e 's/\$(pkgdatadir)/$(DESTDIR)&/' \
+ data/Makefile.in \
+ || die
+}
+
+src_install () {
+ emake DESTDIR="${D}" install
+ newicon data/images/${PN}-icon.xpm ${PN}.xpm
+ make_desktop_entry ${PN} "Circus Linux!"
+ dodoc *.txt
+ prepgamesdirs
+}
diff --git a/games-arcade/circuslinux/metadata.xml b/games-arcade/circuslinux/metadata.xml
new file mode 100644
index 000000000000..78274e0fa550
--- /dev/null
+++ b/games-arcade/circuslinux/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+</maintainer>
+</pkgmetadata>