summaryrefslogtreecommitdiff
path: root/games-arcade/berusky/berusky-1.7.1-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-arcade/berusky/berusky-1.7.1-r1.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-arcade/berusky/berusky-1.7.1-r1.ebuild')
-rw-r--r--games-arcade/berusky/berusky-1.7.1-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/games-arcade/berusky/berusky-1.7.1-r1.ebuild b/games-arcade/berusky/berusky-1.7.1-r1.ebuild
new file mode 100644
index 000000000000..d56b0203f7d5
--- /dev/null
+++ b/games-arcade/berusky/berusky-1.7.1-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit desktop gnome2
+
+DATAFILE="${PN}-data-1.7"
+DESCRIPTION="Free logic game based on an ancient puzzle named Sokoban"
+HOMEPAGE="http://anakreon.cz/?q=node/1"
+SRC_URI="http://www.anakreon.cz/download/${P}.tar.gz
+ http://www.anakreon.cz/download/${DATAFILE}.tar.gz
+ https://dev.gentoo.org/~hasufell/distfiles/${PN}.png"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ media-libs/libsdl[X,video]
+ media-libs/sdl-image[png]
+ x11-libs/gtk+:2
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+
+src_install() {
+ gnome2_src_install
+ rm -rf "${ED}"/usr/doc
+ doicon -s 32 "${DISTDIR}"/${PN}.png
+ make_desktop_entry ${PN}
+}