summaryrefslogtreecommitdiff
path: root/games-arcade/aop
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-arcade/aop
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-arcade/aop')
-rw-r--r--games-arcade/aop/Manifest4
-rw-r--r--games-arcade/aop/aop-0.6-r1.ebuild32
-rw-r--r--games-arcade/aop/files/aop-0.6-as-needed.patch9
-rw-r--r--games-arcade/aop/metadata.xml8
4 files changed, 53 insertions, 0 deletions
diff --git a/games-arcade/aop/Manifest b/games-arcade/aop/Manifest
new file mode 100644
index 000000000000..17bf26f2798b
--- /dev/null
+++ b/games-arcade/aop/Manifest
@@ -0,0 +1,4 @@
+AUX aop-0.6-as-needed.patch 207 BLAKE2B f2baabf390d7376b55a815c256d0c63194a16d822abfbbc7103cd08463e6b193d443c0404cd691085f8a8a849cc14de98c642ff177ce7b6dae5d0e250bc264fc SHA512 4da201cc444e943f21287208944dae0fa981697af97618268ff94699f1ec52c8fcabcbe2b609f3ab36f4c19fdfdf4c76f7acbcfebe6978bb2740ba02a6c8ecc7
+DIST aop-0.6.tar.gz 11811 BLAKE2B 9b8a278ac4afb33dc9bb79d92343f9cf0fb4968aae04898700c948d01788cf33523989583ef39661142e0078e31488b24f8bf1a6bd9586e00afc4f7248fc8ca1 SHA512 0ce37647a0832b17e23df409633952f902e02666fa536cc4393a35bf91b245a501feeb4f14fd16d1a1d5c4f39682dad18a8e671e107e96cf5ba9c89965f8a77c
+EBUILD aop-0.6-r1.ebuild 673 BLAKE2B 635a6f335ecc03a1a84925b73a3dc2d24d071fd6d69bbcaf12a67f913e248e5bcffc78d603551763a8d964f78d6fc51d1595fa4dcfda9f5e3b38623aae758c3c SHA512 b15df56a050d264f05ca9c2d8c292e0a508443b12c730d07f463549b00397c78853e5351cba9a7411c8c6c22e109e0ae78959eaa42efbe584b50766feb566f9c
+MISC metadata.xml 249 BLAKE2B 7113a758d7abc93accec998a8843d8ef51ca8b72d72e659e224d5cec2a1a6a63e6c0605958091532ac6e51fa0d501ca4fd9f3f4a9e55baeb31519a02971b465f SHA512 895577c3a805c40581da03057b94e3f28f05f23012bf350c1e3575847d1a0fe40bb044a46f909012a200d991a400f6389358a60e9c2b5bef0da01fb26f846118
diff --git a/games-arcade/aop/aop-0.6-r1.ebuild b/games-arcade/aop/aop-0.6-r1.ebuild
new file mode 100644
index 000000000000..751bc0e7fd13
--- /dev/null
+++ b/games-arcade/aop/aop-0.6-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Ambassador of Pain is a curses based game with only 64 lines of code"
+HOMEPAGE="http://raffi.at/view/code/aop"
+SRC_URI="http://www.raffi.at/code/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND="sys-libs/ncurses:0"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ default
+ sed -i \
+ -e "s#/usr/local/share#${GAMES_DATADIR}#" \
+ aop.c || die
+ eapply "${FILESDIR}"/${P}-as-needed.patch
+}
+
+src_install() {
+ dobin aop
+ insinto "/usr/shate/${PN}"
+ doins aop-level-*.txt
+ einstalldocs
+}
diff --git a/games-arcade/aop/files/aop-0.6-as-needed.patch b/games-arcade/aop/files/aop-0.6-as-needed.patch
new file mode 100644
index 000000000000..f172919553b4
--- /dev/null
+++ b/games-arcade/aop/files/aop-0.6-as-needed.patch
@@ -0,0 +1,9 @@
+--- a/Makefile.old 2009-01-30 17:00:58.000000000 +0100
++++ b/Makefile 2009-01-30 17:01:15.000000000 +0100
+@@ -1,5 +1,5 @@
+
+-LDFLAGS = -lncurses
++LDLIBS := $(shell pkg-config ncurses --libs)
+
+ aop: aop.c
+
diff --git a/games-arcade/aop/metadata.xml b/games-arcade/aop/metadata.xml
new file mode 100644
index 000000000000..78274e0fa550
--- /dev/null
+++ b/games-arcade/aop/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+</maintainer>
+</pkgmetadata>