summaryrefslogtreecommitdiff
path: root/games-arcade/amphetamine/amphetamine-0.8.10-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-arcade/amphetamine/amphetamine-0.8.10-r1.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-arcade/amphetamine/amphetamine-0.8.10-r1.ebuild')
-rw-r--r--games-arcade/amphetamine/amphetamine-0.8.10-r1.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/games-arcade/amphetamine/amphetamine-0.8.10-r1.ebuild b/games-arcade/amphetamine/amphetamine-0.8.10-r1.ebuild
new file mode 100644
index 000000000000..8df81545c760
--- /dev/null
+++ b/games-arcade/amphetamine/amphetamine-0.8.10-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit desktop
+
+DESCRIPTION="a cool Jump'n Run game offering some unique visual effects"
+HOMEPAGE="http://homepage.hispeed.ch/loehrer/amph/amph.html"
+SRC_URI="http://homepage.hispeed.ch/loehrer/amph/files/${P}.tar.bz2
+ http://homepage.hispeed.ch/loehrer/amph/files/${PN}-data-0.8.6.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND="media-libs/libsdl[sound,video]
+ x11-libs/libXpm"
+RDEPEND=${DEPEND}
+
+PATCHES=(
+ "${FILESDIR}"/${P}-build.patch
+ "${FILESDIR}"/${P}-64bit.patch
+
+ # From Debian:
+ "${FILESDIR}"/${P}-no-lxt.patch
+ "${FILESDIR}"/${P}-bugs.patch
+ "${FILESDIR}"/${P}-missing-headers.patch
+ "${FILESDIR}"/${P}-newline.patch
+)
+
+src_prepare() {
+ default
+ sed -i -e '55d' src/ObjInfo.cpp || die
+}
+
+src_compile() {
+ emake INSTALL_DIR=/usr/share/${PN}
+}
+
+src_install() {
+ newbin amph ${PN}
+ insinto /usr/share/${PN}
+ doins -r ../amph/*
+ newicon amph.xpm ${PN}.xpm
+ make_desktop_entry ${PN} Amphetamine ${PN}
+ einstalldocs
+}