summaryrefslogtreecommitdiff
path: root/games-action
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-17 19:45:55 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-17 19:45:55 +0100
commit59fb6ea4eff116f078307a57217645762b78aba7 (patch)
treebc4b009c0fb67e5716ad01ba8306a486fe4744ed /games-action
parent197f0639ca0a63b397552e059e2a992d39e09e55 (diff)
gentoo auto-resync : 17:06:2023 - 19:45:55
Diffstat (limited to 'games-action')
-rw-r--r--games-action/Manifest.gzbin14529 -> 14865 bytes
-rw-r--r--games-action/psychonauts-gog/Manifest3
-rw-r--r--games-action/psychonauts-gog/metadata.xml14
-rw-r--r--games-action/psychonauts-gog/psychonauts-gog-2.0.0.4.ebuild61
-rw-r--r--games-action/psychonauts-hb/Manifest3
-rw-r--r--games-action/psychonauts-hb/metadata.xml14
-rw-r--r--games-action/psychonauts-hb/psychonauts-hb-20130506.ebuild71
7 files changed, 166 insertions, 0 deletions
diff --git a/games-action/Manifest.gz b/games-action/Manifest.gz
index 36d7a5c03be6..522e8dc59159 100644
--- a/games-action/Manifest.gz
+++ b/games-action/Manifest.gz
Binary files differ
diff --git a/games-action/psychonauts-gog/Manifest b/games-action/psychonauts-gog/Manifest
new file mode 100644
index 000000000000..4062ed802c96
--- /dev/null
+++ b/games-action/psychonauts-gog/Manifest
@@ -0,0 +1,3 @@
+DIST gog_psychonauts_2.0.0.4.sh 4424617772 BLAKE2B 4102a7e23f71857c969349be3eb5b5fa4780d02ec92945a0be13098af4fa30d04fe4294e0fd5b3bd64dfe731a252ee4bcb73c07ca15df4dc532f26e12ed0335d SHA512 5f8cbcbd2eecab66f0a3bc555a6850536dd124fe720d6fe7eba0a56964978b045daac14630ec2e2f9129a3c6cf263baf5cbe65b15f08bc5cd5f754f35b3629a9
+EBUILD psychonauts-gog-2.0.0.4.ebuild 1300 BLAKE2B 534a2ecaf6daba3efeb0ff590579edf72c760a67b175da61de362d68bccca7c1c883053865df48f9a3965f57c37c52b7e047cd627044c44b15fb057fa1971234 SHA512 78dd7ec31b6f93d7814d8da06c17b2719636693de8dc77dd21b29f4d4474324cffa3a44374fd1830eb54df3c78f5ded87d5eb50d248a0d03fd56dc15859409d4
+MISC metadata.xml 539 BLAKE2B 63a0be6c8ba2f49f5bffb149fb37f306695444f8d61ea5232e110463567cd6062c526d7715f63e6926cea84d6cde74eef35a760b2e33e3339095c1b844b877cf SHA512 b813129a415f10afa2c68650e963d3f3149518716965fca98a2d7d6649f0455afbb0565dfba7f545aa67fed2986b2c1740c793a99f3367eb8c5a12afb0bf398c
diff --git a/games-action/psychonauts-gog/metadata.xml b/games-action/psychonauts-gog/metadata.xml
new file mode 100644
index 000000000000..6366a89a523f
--- /dev/null
+++ b/games-action/psychonauts-gog/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ A Psychic Odyssey Through the Mental Worlds of Misfits, Monsters, and
+ Mind Readers. This classic action/adventure platformer from acclaimed
+ developers Double Fine Productions follows the story of a young psychic
+ named Razputin.
+ </longdescription>
+</pkgmetadata>
diff --git a/games-action/psychonauts-gog/psychonauts-gog-2.0.0.4.ebuild b/games-action/psychonauts-gog/psychonauts-gog-2.0.0.4.ebuild
new file mode 100644
index 000000000000..bfe45f2b11b3
--- /dev/null
+++ b/games-action/psychonauts-gog/psychonauts-gog-2.0.0.4.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+CHECKREQS_DISK_BUILD="5238M"
+inherit check-reqs desktop unpacker wrapper xdg
+
+MY_PN="Psychonauts"
+
+DESCRIPTION="A mind-bending platforming adventure from Double Fine Productions"
+HOMEPAGE="https://www.doublefine.com/games/psychonauts"
+SRC_URI="gog_${MY_PN,,}_${PV}.sh"
+
+LICENSE="GOG-EULA"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="bindist fetch splitdebug"
+
+BDEPEND="
+ app-arch/unzip
+"
+
+RDEPEND="
+ media-libs/libsdl[abi_x86_32,opengl,video]
+ media-libs/openal[abi_x86_32]
+ >=sys-devel/gcc-3.4[cxx]
+ sys-libs/glibc
+ !${CATEGORY}/${MY_PN,,}
+ !${CATEGORY}/${MY_PN,,}-hb
+"
+
+S="${WORKDIR}/data/noarch"
+DIR="/opt/${MY_PN,,}"
+QA_PREBUILT="${DIR#/}/*"
+
+pkg_nofetch() {
+ elog "Please buy and download ${SRC_URI} from:"
+ elog " https://www.gog.com/game/${MY_PN,,}"
+ elog "and move it to your distfiles directory."
+}
+
+src_unpack() {
+ unpack_zip ${A}
+}
+
+src_install() {
+ exeinto "${DIR}"
+ doexe game/${MY_PN}
+ make_wrapper ${MY_PN,,} "${DIR}"/${MY_PN}
+
+ insinto "${DIR}"
+ doins -r game/{icon.bmp,WorkResource/,*.pkg}
+
+ newicon -s 256 support/icon.png ${MY_PN,,}.png
+ make_desktop_entry ${MY_PN,,} ${MY_PN} ${MY_PN,,}
+
+ dodoc \
+ docs/"Psychonauts Manual Win.pdf" \
+ game/Documents/Readmes/*.txt
+}
diff --git a/games-action/psychonauts-hb/Manifest b/games-action/psychonauts-hb/Manifest
new file mode 100644
index 000000000000..1222b3731a22
--- /dev/null
+++ b/games-action/psychonauts-hb/Manifest
@@ -0,0 +1,3 @@
+DIST psychonauts-linux-05062013-bin 4419978962 BLAKE2B a5942c9566c3895e3e7e933ebc21ae3688cd74d03966b74cd593e68b5faa7ead27f7d548c21d062f09a5ce1d460cbe132951b849ca9a29e0a2dfb8d5ce6a3d4d SHA512 623bbb2556e3ec0bb9fd3a02913199dcc14d68e74f591409793df37965baded4423fd931ec322a0ebb3724f78efd2d81e5c43fc048dff29b8a84694d3b7f5672
+EBUILD psychonauts-hb-20130506.ebuild 1583 BLAKE2B 6eefde670b7b099cfc69fdd8bfaf2571b99f439313f3f644aeb6efcf7d39d5e86d6c980ceb5687f014eaaa92efb38cbb1a59d7b9dc0745f44b344a547c6fcc86 SHA512 c9ac86555bdebdf12c0b9300e2fb9ca369b38001f29d3bb1d5acbeacecec463fedb2b712837a8798002153f56d3e7c577470e1b779893dd0fd257e057d1069f0
+MISC metadata.xml 539 BLAKE2B 63a0be6c8ba2f49f5bffb149fb37f306695444f8d61ea5232e110463567cd6062c526d7715f63e6926cea84d6cde74eef35a760b2e33e3339095c1b844b877cf SHA512 b813129a415f10afa2c68650e963d3f3149518716965fca98a2d7d6649f0455afbb0565dfba7f545aa67fed2986b2c1740c793a99f3367eb8c5a12afb0bf398c
diff --git a/games-action/psychonauts-hb/metadata.xml b/games-action/psychonauts-hb/metadata.xml
new file mode 100644
index 000000000000..6366a89a523f
--- /dev/null
+++ b/games-action/psychonauts-hb/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ A Psychic Odyssey Through the Mental Worlds of Misfits, Monsters, and
+ Mind Readers. This classic action/adventure platformer from acclaimed
+ developers Double Fine Productions follows the story of a young psychic
+ named Razputin.
+ </longdescription>
+</pkgmetadata>
diff --git a/games-action/psychonauts-hb/psychonauts-hb-20130506.ebuild b/games-action/psychonauts-hb/psychonauts-hb-20130506.ebuild
new file mode 100644
index 000000000000..ee8f5adf44f5
--- /dev/null
+++ b/games-action/psychonauts-hb/psychonauts-hb-20130506.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+CHECKREQS_DISK_BUILD="5237M"
+inherit check-reqs desktop unpacker wrapper xdg
+
+MY_PN="Psychonauts"
+
+DESCRIPTION="A mind-bending platforming adventure from Double Fine Productions"
+HOMEPAGE="https://www.doublefine.com/games/psychonauts"
+SRC_URI="${MY_PN,,}-linux-${PV:4:2}${PV:6:2}${PV:0:4}-bin"
+
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="bindist fetch splitdebug"
+
+BDEPEND="
+ app-arch/unzip
+ media-libs/libpng
+"
+
+RDEPEND="
+ media-libs/libsdl[abi_x86_32,opengl,video]
+ media-libs/openal[abi_x86_32]
+ >=sys-devel/gcc-3.4[cxx]
+ sys-libs/glibc
+ !${CATEGORY}/${MY_PN,,}
+ !${CATEGORY}/${MY_PN,,}-gog
+"
+
+S="${WORKDIR}/data"
+DIR="/opt/${MY_PN,,}"
+QA_PREBUILT="${DIR#/}/*"
+
+pkg_nofetch() {
+ elog "Please buy and download ${SRC_URI} from:"
+ elog " https://www.humblebundle.com/store/${MY_PN,,}"
+ elog "and move it to your distfiles directory."
+}
+
+src_unpack() {
+ unpack_zip ${A}
+}
+
+src_prepare() {
+ default
+
+ # The distributed icon is broken so fix it. pngfix exits unsuccessfully when
+ # it fixes an image, so run it again to check the fixed image.
+ pngfix --out="${T}"/${MY_PN,,}.png ${MY_PN,,}.png ||
+ pngfix "${T}"/${MY_PN,,}.png || die
+}
+
+src_install() {
+ exeinto "${DIR}"
+ doexe ${MY_PN}
+ make_wrapper ${MY_PN,,} "${DIR}"/${MY_PN}
+
+ insinto "${DIR}"
+ doins -r icon.bmp WorkResource/ *.pkg
+
+ doicon -s 512 "${T}"/${MY_PN,,}.png
+ make_desktop_entry ${MY_PN,,} ${MY_PN} ${MY_PN,,}
+
+ dodoc \
+ "Psychonauts Manual Win.pdf" \
+ README-linux.txt
+}