summaryrefslogtreecommitdiff
path: root/games-action
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-05-27 00:07:23 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-05-27 00:07:23 +0100
commit3c1648a0749c1d66b300d857e6b417c1162890da (patch)
tree2b13f04c2c10d472e5bb7cc40fe6048bf8bc549d /games-action
parent994fe442814c4d169bb0f1ee9745604928006b39 (diff)
gentoo auto-resync : 27:05:2024 - 00:07:23
Diffstat (limited to 'games-action')
-rw-r--r--games-action/Manifest.gzbin14377 -> 14384 bytes
-rw-r--r--games-action/violetland/Manifest3
-rw-r--r--games-action/violetland/files/violetland-0.5-boost1.85.patch8
-rw-r--r--games-action/violetland/violetland-0.5.ebuild6
4 files changed, 15 insertions, 2 deletions
diff --git a/games-action/Manifest.gz b/games-action/Manifest.gz
index 5182d347c7e9..6878c375cac0 100644
--- a/games-action/Manifest.gz
+++ b/games-action/Manifest.gz
Binary files differ
diff --git a/games-action/violetland/Manifest b/games-action/violetland/Manifest
index ffcb13307eb2..f5a9b1580878 100644
--- a/games-action/violetland/Manifest
+++ b/games-action/violetland/Manifest
@@ -1,3 +1,4 @@
+AUX violetland-0.5-boost1.85.patch 324 BLAKE2B d9709f5bf7aec7a2736f4bf6f490c6ee16c0a09e82d9f8d7286d69f050527bff3f55c27d5378e49e743e341b8d01710f40fe7b974a0f0aec6c4859b955e171bb SHA512 889bde8756f61f8843fc163443f1aaa434ee087a54e1414fba9c1e3933960fb07ebc13626cce39241d7ec1f8e1a2e8a8292064be8a21c26f98e2cf83d83cc230
DIST violetland-0.5-source-with-dependencies.tar.gz 11495885 BLAKE2B 33c3e8a8955ddc416c66c761681dce337ecccdb52ae7be3777124f4854c325436296ea5614100527a3e5be6c4d3a3cf2dffb2336037d5e904b50e2ae843d0fc4 SHA512 9b00fa600332c956c49bc5906f373c0dfff08a13320617014942ac4dbc199de8f84bef87ed218b38812ae3c53622e9148aa4463c4ea219056360bff1c73b7f88
-EBUILD violetland-0.5.ebuild 1294 BLAKE2B f755921921c1c9e1225e401b792b59e56d49dbcd4e254431416f59218fec5a0364ce0ea641cd6801ae7329c2cd627fe5a2ad2f741860cc6670a47cd3137b3c38 SHA512 8eae453930cd02d8c648ed3f5a48c581d686cf93a29410281c0b0d6593232a1c29f81303c762de70c6e114171831c36c536be73a8a33c938e54a7c54341388e2
+EBUILD violetland-0.5.ebuild 1343 BLAKE2B c54c66a19ce5a51c2e7355059e10720e9962696587b29173a6bac252364605dcf2373dc4fb242877c9b61d8fb93a4cde70a9d447e706641156a26474afae3d6a SHA512 22dbacac1c0284625c6acd382c370b04db8474efe288008c9708506675bb799a59eee5d1c12aaddbe0cbe78fe198274c3f04359c4e1734d408f77e13aad31992
MISC metadata.xml 334 BLAKE2B 4bade7bcf268b67f484f32a90bf4ce02e06f1f06259869b6b9b296d4f1384ae69ca63430a217265d95365e524b09d03a2ed964408b07f5c74e0e2a138e0f64b8 SHA512 e588f5cd728c829a1069d6481bf1c66d2a4fb21ec71c2c6b466999769a37722aca5f871968403a7c9301ac976adb343818c918148c9f8bdc8745777530997e39
diff --git a/games-action/violetland/files/violetland-0.5-boost1.85.patch b/games-action/violetland/files/violetland-0.5-boost1.85.patch
new file mode 100644
index 000000000000..8382122c0ccf
--- /dev/null
+++ b/games-action/violetland/files/violetland-0.5-boost1.85.patch
@@ -0,0 +1,8 @@
+https://bugs.gentoo.org/932778
+--- a/src/game/Highscores.cpp
++++ b/src/game/Highscores.cpp
+@@ -107,3 +107,3 @@
+ boost::filesystem::copy_file(hsTempFile, hsFile,
+- boost::filesystem::copy_option::overwrite_if_exists);
++ boost::filesystem::copy_options::overwrite_existing);
+ boost::filesystem::remove(hsTempFile);
diff --git a/games-action/violetland/violetland-0.5.ebuild b/games-action/violetland/violetland-0.5.ebuild
index 21c08d426767..2db7c5ac14cf 100644
--- a/games-action/violetland/violetland-0.5.ebuild
+++ b/games-action/violetland/violetland-0.5.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -28,6 +28,10 @@ BDEPEND="
sys-devel/gettext
"
+PATCHES=(
+ "${FILESDIR}"/${P}-boost1.85.patch
+)
+
src_prepare() {
cmake_src_prepare