summaryrefslogtreecommitdiff
path: root/games-action/xbomber/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:58:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:58:29 +0100
commit0cf2f20608308acdf3cb922c3736446bbd8f3388 (patch)
tree07815070629c7c11000a7f51ceb8ccbccb49a809 /games-action/xbomber/files
parent1798c4aeca70ac8d0a243684d6a798fbc65735f8 (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-action/xbomber/files')
-rw-r--r--games-action/xbomber/files/xbomber-101-clang.patch123
-rw-r--r--games-action/xbomber/files/xbomber-101-gcc4.patch11
-rw-r--r--games-action/xbomber/files/xbomber-101-ldflags.patch15
-rw-r--r--games-action/xbomber/files/xbomber-101-va_list.patch48
4 files changed, 0 insertions, 197 deletions
diff --git a/games-action/xbomber/files/xbomber-101-clang.patch b/games-action/xbomber/files/xbomber-101-clang.patch
deleted file mode 100644
index 1771f15abc5e..000000000000
--- a/games-action/xbomber/files/xbomber-101-clang.patch
+++ /dev/null
@@ -1,123 +0,0 @@
---- a/bomber.c 2016-07-13 16:35:34.596802964 -0500
-+++ b/bomber.c 2016-07-13 16:40:43.110797439 -0500
-@@ -350,7 +350,7 @@
- inform1(i);
- }
-
--networktraffic()
-+void networktraffic()
- {
- int i,j,k;
- int length;
-@@ -1252,7 +1252,7 @@
- }
- }
-
--addsprite(int x,int y,figure *fig)
-+void addsprite(int x,int y,figure *fig)
- {
- sprite *sp;
- if(spritesused==MAXSPRITES) return;
-@@ -1262,7 +1262,7 @@
- sp->ypos=y;
- sp->fig=fig;
- }
--adddamage(int xpos,int ypos,int xsize,int ysize)
-+void adddamage(int xpos,int ypos,int xsize,int ysize)
- {
- damage *dm;
- if(damageused==MAXDAMAGES) return;
-@@ -1375,7 +1375,7 @@
- return (y>>FRACTION)+arraystarty;
- }
-
--int trymove(player *pl,int dx,int dy)
-+void trymove(player *pl,int dx,int dy)
- {
- int wx,wy;
- int sx,sy;
-@@ -1520,7 +1520,7 @@
- }
- }
-
--doplayer(player *pl)
-+void doplayer(player *pl)
- {
- int last;
- int color;
-@@ -1640,7 +1640,7 @@
- 8,14,4,
- };
-
--initplayers()
-+void initplayers()
- {
- int i;
- unsigned char *p;
-@@ -1794,7 +1794,7 @@
- copyup();
- }
-
--pulseon()
-+void pulseon()
- {
- if(havepulse) return;
- havepulse=1;
-@@ -1803,7 +1803,7 @@
- thandler(0);
- setitimer(ITIMER_REAL,&itval,NULL);
- }
--pulseoff()
-+void pulseoff()
- {
- if(!havepulse) return;
- havepulse=0;
-@@ -2235,7 +2235,7 @@
- failure(char *str,...)
- {
- gamemode=0;
-- return;
-+ return 1;
- }
- drawmode3()
- {
-@@ -2261,7 +2261,7 @@
- }
-
-
--domode3()
-+void domode3()
- {
- int size;
- int i,j;
-@@ -2351,7 +2351,7 @@
-
- gamemode=0;
- }
--domode4()
-+void domode4()
- {
- unsigned char querystr[16];
- long now;
---- a/bomber.h 2016-07-13 16:35:34.596802964 -0500
-+++ b/bomber.h 2016-07-13 16:40:26.797797731 -0500
-@@ -210,6 +210,8 @@
- extern void scrprintf(char *str, ...);
- extern int textx,texty,fontxsize,fontysize;
- extern void texthome(void);
-+extern void adddamage(int xpos,int ypos,int xsize,int ysize);
-+extern void addsprite(int x,int y,figure *fig);
-
- extern unsigned char field[32][32];
- extern void *info[32][32];
---- a/sound.c 2016-07-13 16:35:34.596802964 -0500
-+++ b/sound.c 2016-07-13 16:40:57.702797177 -0500
-@@ -44,7 +44,7 @@
-
-
-
--soundinit(char *name)
-+void soundinit(char *name)
- {
- int fd[2];
- char devname[256];
diff --git a/games-action/xbomber/files/xbomber-101-gcc4.patch b/games-action/xbomber/files/xbomber-101-gcc4.patch
deleted file mode 100644
index 0ee82d81801b..000000000000
--- a/games-action/xbomber/files/xbomber-101-gcc4.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/bomber.c 2006-01-28 12:06:34.000000000 -0700
-+++ b/bomber.c 2006-01-28 12:06:46.000000000 -0700
-@@ -1699,7 +1699,7 @@
- }
- void addtail(void *header,void *entry)
- {
-- while(((list *)header)->next) ((list *)header)=((list *)header)->next;
-+ while(((list *)header)->next) header=((list *)header)->next;
- ((list *)header)->next=entry;
- ((list *)entry)->next=0;
- }
diff --git a/games-action/xbomber/files/xbomber-101-ldflags.patch b/games-action/xbomber/files/xbomber-101-ldflags.patch
deleted file mode 100644
index a0bf2f89d735..000000000000
--- a/games-action/xbomber/files/xbomber-101-ldflags.patch
+++ /dev/null
@@ -1,15 +0,0 @@
---- a/Makefile 2010-10-19 09:17:43.000000000 +0200
-+++ b/Makefile 2010-10-19 09:18:12.000000000 +0200
-@@ -1,10 +1,8 @@
--CFLAGS = -O3
--
- bomber: bomber.o x.o sound.o matcher
-- $(CC) -o bomber bomber.o x.o sound.o -lX11 -L/usr/X11R6/lib/
-+ $(CC) $(CFLAGS) $(LDFLAGS) -o bomber bomber.o x.o sound.o -lX11 -L/usr/X11R6/lib/
-
- matcher: matcher.c
-- $(CC) matcher.c -o matcher
-+ $(CC) $(CFLAGS) $(LDFLAGS) matcher.c -o matcher
-
- bomber.o: bomber.c bomber.h
-
diff --git a/games-action/xbomber/files/xbomber-101-va_list.patch b/games-action/xbomber/files/xbomber-101-va_list.patch
deleted file mode 100644
index 5a1691a65ad8..000000000000
--- a/games-action/xbomber/files/xbomber-101-va_list.patch
+++ /dev/null
@@ -1,48 +0,0 @@
---- a/bomber.c 2005-11-06 16:50:04.000000000 +0100
-+++ b/bomber.c 2005-11-06 16:47:35.000000000 +0100
-@@ -1,5 +1,6 @@
- #include <stdio.h>
- #include <stdlib.h>
-+#include <stdarg.h>
- #include <unistd.h>
- #include <string.h>
- #include <sys/uio.h>
-@@ -626,8 +627,11 @@
- void scrprintf(char *str,...)
- {
- char output[256],*p,*p2;
-+va_list ap;
-
-- vsprintf(output,str,&str+1);
-+ va_start(ap, str);
-+ vsprintf(output,str,ap);
-+ va_end(ap);
- p=output;
- for(;;)
- {
-@@ -653,8 +657,11 @@
- void bigscrprintf(char *str,...)
- {
- char output[256],*p,*p2;
-+va_list ap;
-
-- vsprintf(output,str,&str+1);
-+ va_start(ap, str);
-+ vsprintf(output,str,ap);
-+ va_end(ap);
- p=output;
- for(;;)
- {
-@@ -1873,8 +1880,11 @@
- additem(char *item,...)
- {
- char output[256];
-+va_list ap;
-
-- vsprintf(output,item,&item+1);
-+ va_start(ap, item);
-+ vsprintf(output,item,ap);
-+ va_end(ap);
- if(menunum<0)
- menutitle=menuput;
- else