summaryrefslogtreecommitdiff
path: root/games-action/transcend/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /games-action/transcend/files
reinit the tree, so we can have metadata
Diffstat (limited to 'games-action/transcend/files')
-rw-r--r--games-action/transcend/files/transcend-0.3-sound.patch89
1 files changed, 89 insertions, 0 deletions
diff --git a/games-action/transcend/files/transcend-0.3-sound.patch b/games-action/transcend/files/transcend-0.3-sound.patch
new file mode 100644
index 000000000000..836cd03754ad
--- /dev/null
+++ b/games-action/transcend/files/transcend-0.3-sound.patch
@@ -0,0 +1,89 @@
+Author: Barry deFreese <bdefreese@debian.org>
+Description: Build with portaudio19.
+--- a/game/SoundPlayer.h
++++ b/game/SoundPlayer.h
+@@ -204,7 +204,7 @@
+ double mMusicLoudness;
+
+
+- PortAudioStream *mAudioStream;
++ PaStream *mAudioStream;
+
+ // realtime sounds that should be mixed into the next to-speaker call
+ SimpleVector<PlayableSound *> *mRealtimeSounds;
+--- a/game/SoundPlayer.cpp
++++ b/game/SoundPlayer.cpp
+@@ -47,9 +47,11 @@
+
+
+ // callback passed into portaudio
+-static int portaudioCallback( void *inputBuffer, void *outputBuffer,
++int portaudioCallback( const void *inputBuffer, void *outputBuffer,
+ unsigned long framesPerBuffer,
+- PaTimestamp outTime, void *userData ) {
++ const PaStreamCallbackTimeInfo *outTime,
++ PaStreamCallbackFlags statusFlags,
++ void *userData ) {
+
+
+ SoundPlayer *player = (SoundPlayer *)userData;
+@@ -147,21 +149,13 @@
+
+ if( error == paNoError ) {
+
+- error = Pa_OpenStream(
++ error = Pa_OpenDefaultStream(
+ &mAudioStream,
+- paNoDevice,// default input device
+ 0, // no input
+- paFloat32, // 32 bit floating point input
+- NULL,
+- Pa_GetDefaultOutputDeviceID(),
+ 2, // stereo output
+ paFloat32, // 32 bit floating point output
+- NULL,
+ mSampleRate,
+ 1024, // frames per buffer
+- 0, // number of buffers, if zero then use default minimum
+- paClipOff, // we won't output out of range samples so
+- // don't bother clipping them
+ portaudioCallback,
+ (void *)this ); // pass self-pointer to callback function
+
+Description: Link to dynamic portaudio instead of static.
+Author: Miriam Ruiz <miriam@debian.org>
+--- a/Makefile.GnuLinuxX86
++++ b/Makefile.GnuLinuxX86
+@@ -22,7 +22,7 @@
+
+ # pthread library needed for linux
+ # also need portaudio library (which in turn needs pthreads)
+-PLATFORM_LINK_FLAGS = -L/usr/X11R6/lib -lGL -lglut -lGLU -lX11 -lXi -lXext -lXmu ${ROOT_PATH}/Transcend/portaudio/lib/libportaudio.a -lpthread
++PLATFORM_LINK_FLAGS = -L/usr/X11R6/lib -lGL -lglut -lGLU -lX11 -lXi -lXext -lXmu $(shell pkg-config portaudio-2.0 --libs)
+
+
+ # All platforms but OSX support g++ and need no linker hacks
+--- a/game/SoundPlayer.h
++++ b/game/SoundPlayer.h
+@@ -46,8 +46,7 @@
+ #include "SoundFilter.h"
+ #include "PlayableSound.h"
+
+-#include "Transcend/portaudio/pa_common/portaudio.h"
+-#include "Transcend/portaudio/pablio/pablio.h"
++#include <portaudio.h>
+
+
+ #include "minorGems/util/SimpleVector.h"
+--- a/game/SoundPlayerActive.h
++++ b/game/SoundPlayerActive.h
+@@ -16,8 +16,7 @@
+
+ #include "SoundSamples.h"
+
+-#include "Transcend/portaudio/pa_common/portaudio.h"
+-#include "Transcend/portaudio/pablio/pablio.h"
++#include <portaudio.h>
+
+
+ #include "minorGems/util/SimpleVector.h"