summaryrefslogtreecommitdiff
path: root/games-action/supertuxkart/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-05-18 00:10:51 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-05-18 00:10:51 +0100
commiteccb70a7f91b2d22582587f26d1a28bb31408b45 (patch)
tree3223e1fd54201bcf4ebecac6fbe87361cbe643e2 /games-action/supertuxkart/files
parenta2810985afabcc31d3eace5e61d8ea25b852ba17 (diff)
gentoo resync : 18.05.2019
Diffstat (limited to 'games-action/supertuxkart/files')
-rw-r--r--games-action/supertuxkart/files/supertuxkart-0.9.3-fix-buildsystem.patch103
-rw-r--r--games-action/supertuxkart/files/supertuxkart-0.9.3-intrin.patch56
-rw-r--r--games-action/supertuxkart/files/supertuxkart-0.9.3-irrlicht-bundled-libs.patch33
-rw-r--r--games-action/supertuxkart/files/supertuxkart-0.9.3-unbundle-enet.patch57
-rw-r--r--games-action/supertuxkart/files/supertuxkart-0.9.3-unbundle-libs.patch19
-rw-r--r--games-action/supertuxkart/files/supertuxkart-1.0-fix-buildsystem.patch20
-rw-r--r--games-action/supertuxkart/files/supertuxkart-1.0-system-squish.patch43
7 files changed, 63 insertions, 268 deletions
diff --git a/games-action/supertuxkart/files/supertuxkart-0.9.3-fix-buildsystem.patch b/games-action/supertuxkart/files/supertuxkart-0.9.3-fix-buildsystem.patch
deleted file mode 100644
index def5c80340ba..000000000000
--- a/games-action/supertuxkart/files/supertuxkart-0.9.3-fix-buildsystem.patch
+++ /dev/null
@@ -1,103 +0,0 @@
-* Unbundle remaining libraries: GLEW, zlib, png, jpeg
-* Add -DAS_DEPRECATED for Angelscript
-* Remove definition of debug macros
-* Build bundled Irrlicht with user flags
-
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -110,43 +110,11 @@
- include_directories(${ENET_INCLUDE_DIR})
-
- # Build glew library
- if(NOT USE_GLES2 AND NOT SERVER_ONLY)
-+ find_package(GLEW REQUIRED)
-+ include_directories(${GLEW_INCLUDE_DIRS})
- add_definitions(-DGLEW_NO_GLU)
-- add_subdirectory("${PROJECT_SOURCE_DIR}/lib/glew")
-- include_directories("${PROJECT_SOURCE_DIR}/lib/glew/include")
- endif()
-
--if(MSVC OR APPLE)
-- if (NOT APPLE)
-- # Build zlib library
-- add_subdirectory("${PROJECT_SOURCE_DIR}/lib/zlib")
-- include_directories("${PROJECT_SOURCE_DIR}/lib/zlib")
--
-- set(ZLIB_INCLUDE_DIR "${PROJECT_SOURCE_DIR}/lib/zlib" "${PROJECT_BINARY_DIR}/lib/zlib/")
-- set(ZLIB_LIBRARY zlibstatic)
-- endif()
--
-- # Build png library
-- set(SKIP_INSTALL_ALL TRUE)
-- set(PNG_STATIC TRUE CACHE BOOL "Build static lib")
-- set(PNG_TESTS FALSE CACHE BOOL "Build libpng tests")
-- set(PNG_SHARED FALSE CACHE BOOL "Build shared lib")
-- add_subdirectory("${PROJECT_SOURCE_DIR}/lib/libpng")
-- include_directories("${PROJECT_SOURCE_DIR}/lib/libpng")
--
-- set(PNG_PNG_INCLUDE_DIR "${PROJECT_SOURCE_DIR}/lib/libpng/")
-- set(PNG_LIBRARY png_static)
--endif()
--
--# Add jpeg library
--if (APPLE)
-- add_subdirectory("${PROJECT_SOURCE_DIR}/lib/jpeglib")
-- include_directories("${PROJECT_SOURCE_DIR}/lib/jpeglib")
-- set(JPEG_INCLUDE_DIR "${PROJECT_SOURCE_DIR}/lib/jpeglib/")
-- set(JPEG_LIBRARY jpeglib)
--else()
-- find_package(JPEG REQUIRED)
-- include_directories(${JPEG_INCLUDE_DIR})
--endif()
-
- if (BUILD_RECORDER)
-@@ -206,6 +174,7 @@
- find_package(Angelscript)
- if(ANGELSCRIPT_FOUND)
- include_directories(${Angelscript_INCLUDE_DIRS})
-+ add_definitions(-DAS_DEPRECATED)
- else()
- message(FATAL_ERROR "Angelscript not found. "
- "Either install angelscript or use built-in version using "
-@@ -307,14 +276,6 @@
- # VS will automatically add NDEBUG for release mode, but only _DEBUG in debug mode.
- # Since STK uses DEBUG, this is added for debug compilation only:
- set_property(DIRECTORY PROPERTY COMPILE_DEFINITIONS_DEBUG DEBUG)
--else()
-- # All non VS generators used create only a single compile mode, so
-- # compile flags can be simplye be added
-- if(CMAKE_BUILD_TYPE MATCHES Debug)
-- add_definitions(-DDEBUG)
-- else()
-- add_definitions(-DNDEBUG)
-- endif()
- endif()
-
- # TODO: remove this switch
-@@ -426,7 +395,7 @@
- if(NOT SERVER_ONLY)
- if(NOT USE_GLES2)
-- target_link_libraries(supertuxkart ${OPENGL_gl_LIBRARY} glew graphics_utils)
-+ target_link_libraries(supertuxkart ${OPENGL_gl_LIBRARY} ${GLEW_LIBRARIES} graphics_utils)
- else()
- target_link_libraries(supertuxkart GLESv2)
- endif()
- endif()
---- a/lib/irrlicht/CMakeLists.txt
-+++ b/lib/irrlicht/CMakeLists.txt
-@@ -68,15 +68,6 @@
- if(WIN32)
- add_definitions(-D_IRR_STATIC_LIB_)
- add_definitions(-D_CRT_SECURE_NO_WARNINGS) # Shut up about unsafe stuff
--else()
-- set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wall -pipe -O3 -fno-exceptions -fstrict-aliasing")
-- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wall -pipe -O3 -fno-exceptions -fstrict-aliasing")
-- if(CMAKE_COMPILER_IS_GNUCC)
-- set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -fexpensive-optimizations")
-- endif()
-- if(CMAKE_COMPILER_IS_GNUCXX)
-- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -fexpensive-optimizations")
-- endif()
- endif()
-
- if(USE_GLES2)
diff --git a/games-action/supertuxkart/files/supertuxkart-0.9.3-intrin.patch b/games-action/supertuxkart/files/supertuxkart-0.9.3-intrin.patch
deleted file mode 100644
index 75830b8ba8f2..000000000000
--- a/games-action/supertuxkart/files/supertuxkart-0.9.3-intrin.patch
+++ /dev/null
@@ -1,56 +0,0 @@
-From 813b08bc73e4e93714b972ee56c64b4771735e01 Mon Sep 17 00:00:00 2001
-From: Benau <Benau@users.noreply.github.com>
-Date: Sun, 14 Jan 2018 10:19:37 +0800
-Subject: [PATCH] Fix #3091
-
----
- lib/graphics_utils/mipmap/cpusimd.h | 14 +++++++-------
- 1 file changed, 7 insertions(+), 7 deletions(-)
-
-diff --git a/lib/graphics_utils/mipmap/cpusimd.h b/lib/graphics_utils/mipmap/cpusimd.h
-index 1dc2c730b2..5e2cf30e5f 100644
---- a/lib/graphics_utils/mipmap/cpusimd.h
-+++ b/lib/graphics_utils/mipmap/cpusimd.h
-@@ -38,11 +38,11 @@
- #include <mmintrin.h>
- #define CPU_MMX_SUPPORT (1)
- #endif
--#if __SSE__ || _M_X64 || _M_IX86_FP >= 1 || CPU_ENABLE_SSE
-+#if __SSE__ || defined(_M_X64) || ( defined(_M_IX86_FP) && ( _M_IX86_FP >= 1 ) ) || CPU_ENABLE_SSE
- #include <xmmintrin.h>
- #define CPU_SSE_SUPPORT (1)
- #endif
--#if __SSE2__ || _M_X64 || _M_IX86_FP >= 2 || CPU_ENABLE_SSE2
-+#if __SSE2__ || defined(_M_X64) || ( defined(_M_IX86_FP) && ( _M_IX86_FP >= 2 ) ) || CPU_ENABLE_SSE2
- #include <emmintrin.h>
- #define CPU_SSE2_SUPPORT (1)
- #endif
-@@ -95,23 +95,23 @@
- #define CPU_POPCNT_SUPPORT (1)
- #endif
- #if __LZCNT__ || CPU_ENABLE_LZCNT
-- #include <lzcntintrin.h>
-+ #include <x86intrin.h>
- #define CPU_LZCNT_SUPPORT (1)
- #endif
- #if __F16C__ || CPU_ENABLE_F16C
-- #include <f16cintrin.h>
-+ #include <x86intrin.h>
- #define CPU_F16C_SUPPORT (1)
- #endif
- #if __BMI__ || CPU_ENABLE_BMI
-- #include <bmiintrin.h>
-+ #include <x86intrin.h>
- #define CPU_BMI_SUPPORT (1)
- #endif
- #if __BMI2__ || CPU_ENABLE_BMI2
-- #include <bmi2intrin.h>
-+ #include <x86intrin.h>
- #define CPU_BMI2_SUPPORT (1)
- #endif
- #if __TBM__ || CPU_ENABLE_TBM
-- #include <tbmintrin.h>
-+ #include <x86intrin.h>
- #define CPU_TBM_SUPPORT (1)
- #endif
-
diff --git a/games-action/supertuxkart/files/supertuxkart-0.9.3-irrlicht-bundled-libs.patch b/games-action/supertuxkart/files/supertuxkart-0.9.3-irrlicht-bundled-libs.patch
deleted file mode 100644
index 194f278b958d..000000000000
--- a/games-action/supertuxkart/files/supertuxkart-0.9.3-irrlicht-bundled-libs.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-Description: Remove embedded libraries in Irrlicht source (flagged by lintian)
- Since removing the subdirectories containing libjpeg/libpng/zlib/bzip2/lzma
- would make this patch way too large, this patch should be applied on top of
- rm -rf lib/jpeglib/
- rm -rf lib/zlib/
- rm -rf lib/libpng/
- in debian/rules (e.g. in the clean target).
-Forwarded: no
-Author: Vincent Cheng <vcheng@debian.org>
-Last-Update: 2016-07-07
-
---- a/lib/irrlicht/CMakeLists.txt
-+++ b/lib/irrlicht/CMakeLists.txt
-@@ -2,9 +2,6 @@
- find_package(PNG REQUIRED)
- find_package(JPEG REQUIRED)
-
--include_directories("${CMAKE_CURRENT_SOURCE_DIR}/include/"
-- "${JPEG_INCLUDE_DIR}"
-- "${PNG_INCLUDE_DIRS}"
-- "${ZLIB_INCLUDE_DIR}")
-+include_directories(${CMAKE_CURRENT_SOURCE_DIR}/include/)
-
- if(MSVC OR APPLE)
-@@ -576,7 +573,7 @@
- endif()
-
- add_library(stkirrlicht STATIC ${IRRLICHT_SOURCES})
-
--target_link_libraries(stkirrlicht ${PNG_LIBRARY} ${JPEG_LIBRARY} ${ZLIB_LIBRARY})
-+target_link_libraries(stkirrlicht png jpeg z)
-
- if(NOT SERVER_ONLY)
diff --git a/games-action/supertuxkart/files/supertuxkart-0.9.3-unbundle-enet.patch b/games-action/supertuxkart/files/supertuxkart-0.9.3-unbundle-enet.patch
deleted file mode 100644
index 8c00fce7e186..000000000000
--- a/games-action/supertuxkart/files/supertuxkart-0.9.3-unbundle-enet.patch
+++ /dev/null
@@ -1,57 +0,0 @@
-Description: Build supertuxkart against system enet instead of embedded copy
-Forwarded: not-yet
-Author: Vincent Cheng <vcheng@debian.org>
-Last-Update: 2016-07-17
-
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -105,9 +105,9 @@
- add_subdirectory("${PROJECT_SOURCE_DIR}/lib/bullet")
- include_directories("${PROJECT_SOURCE_DIR}/lib/bullet/src")
-
--# Build the ENet UDP network library
--add_subdirectory("${PROJECT_SOURCE_DIR}/lib/enet")
--include_directories("${PROJECT_SOURCE_DIR}/lib/enet/include")
-+# ENet
-+find_package(ENet REQUIRED)
-+include_directories(${ENET_INCLUDE_DIR})
-
- # Build glew library
- if(NOT USE_GLES2 AND NOT SERVER_ONLY)
-@@ -406,10 +406,10 @@
- bulletdynamics
- bulletcollision
- bulletmath
-- enet
- stkirrlicht
- ${Angelscript_LIBRARIES}
- ${CURL_LIBRARIES}
-+ ${ENET_LIBRARIES}
- ${OGGVORBIS_LIBRARIES}
- ${OPENAL_LIBRARY}
- ${FREETYPE_LIBRARIES}
---- /dev/null
-+++ b/cmake/FindENet.cmake
-@@ -0,0 +1,22 @@
-+# - Find ENet
-+# Find the ENet includes and libraries
-+#
-+# Following variables are provided:
-+# ENET_FOUND
-+# True if ENet has been found
-+# ENET_INCLUDE_DIR
-+# The include directories of ENet
-+# ENET_LIBRARIES
-+# ENet library list
-+
-+
-+find_path(ENET_INCLUDE_DIR enet/enet.h /usr/include)
-+find_library(ENET_LIBRARY NAMES enet PATHS /usr/lib)
-+
-+include(FindPackageHandleStandardArgs)
-+find_package_handle_standard_args(ENet DEFAULT_MSG ENET_INCLUDE_DIR ENET_LIBRARY)
-+
-+# Publish variables
-+set(ENET_INCLUDE_DIRS ${ENET_INCLUDE_DIR})
-+set(ENET_LIBRARIES ${ENET_LIBRARY})
-+mark_as_advanced(ENET_INCLUDE_DIR ENET_LIBRARY)
diff --git a/games-action/supertuxkart/files/supertuxkart-0.9.3-unbundle-libs.patch b/games-action/supertuxkart/files/supertuxkart-0.9.3-unbundle-libs.patch
deleted file mode 100644
index 798a6cdea7ac..000000000000
--- a/games-action/supertuxkart/files/supertuxkart-0.9.3-unbundle-libs.patch
+++ /dev/null
@@ -1,19 +0,0 @@
-Description: Link against system copies of zlib/libpng/libjpeg/bzip2
-Forwarded: not-yet
-Author: Vincent Cheng <vcheng@debian.org>
-Last-Update: 2016-07-17
-
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -416,6 +416,11 @@
- ${JPEG_LIBRARIES}
- ${TURBOJPEG_LIBRARY}
- #${VPX_LIBRARIES}
-+ X11
-+ z
-+ png
-+ jpeg
-+ bz2
- )
-
- if(NOT SERVER_ONLY)
diff --git a/games-action/supertuxkart/files/supertuxkart-1.0-fix-buildsystem.patch b/games-action/supertuxkart/files/supertuxkart-1.0-fix-buildsystem.patch
new file mode 100644
index 000000000000..23e8280a18f4
--- /dev/null
+++ b/games-action/supertuxkart/files/supertuxkart-1.0-fix-buildsystem.patch
@@ -0,0 +1,20 @@
+diff --git a/lib/irrlicht/CMakeLists.txt b/lib/irrlicht/CMakeLists.txt
+index 92a881c81..1371fdf11 100644
+--- a/lib/irrlicht/CMakeLists.txt
++++ b/lib/irrlicht/CMakeLists.txt
+@@ -96,15 +96,6 @@ endif()
+ if(WIN32)
+ add_definitions(-D_IRR_STATIC_LIB_)
+ add_definitions(-D_CRT_SECURE_NO_WARNINGS) # Shut up about unsafe stuff
+-else()
+- set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wall -pipe -O3 -fno-exceptions -fstrict-aliasing")
+- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wall -pipe -O3 -fno-exceptions -fstrict-aliasing")
+- if(CMAKE_COMPILER_IS_GNUCC)
+- set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -fexpensive-optimizations")
+- endif()
+- if(CMAKE_COMPILER_IS_GNUCXX)
+- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -fexpensive-optimizations")
+- endif()
+ endif()
+
+ if(USE_GLES2)
diff --git a/games-action/supertuxkart/files/supertuxkart-1.0-system-squish.patch b/games-action/supertuxkart/files/supertuxkart-1.0-system-squish.patch
new file mode 100644
index 000000000000..8158c4bb9e5e
--- /dev/null
+++ b/games-action/supertuxkart/files/supertuxkart-1.0-system-squish.patch
@@ -0,0 +1,43 @@
+From e1601b1ae07e3c1ac05cffe05b82e0c60998bc72 Mon Sep 17 00:00:00 2001
+From: James Le Cuirot <chewi@gentoo.org>
+Date: Mon, 13 May 2019 22:51:21 +0100
+Subject: [PATCH] CMake: Add option to use system Squish library
+
+The system version was preferred before but it wasn't possible to
+explicitly disable it, making its use automagic, which is bad for
+packaging.
+
+Closes: https://github.com/supertuxkart/stk-code/pull/3916
+---
+ CMakeLists.txt | 8 ++++++--
+ 1 file changed, 6 insertions(+), 2 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 8a7f03264..40e7790fe 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -31,6 +31,8 @@ CMAKE_DEPENDENT_OPTION(BUILD_RECORDER "Build opengl recorder" ON
+ "NOT SERVER_ONLY;NOT APPLE" OFF)
+ CMAKE_DEPENDENT_OPTION(USE_FRIBIDI "Support for right-to-left languages" ON
+ "NOT SERVER_ONLY" OFF)
++CMAKE_DEPENDENT_OPTION(USE_SYSTEM_SQUISH "Use system Squish library instead of the built-in version, when available." ON
++ "NOT SERVER_ONLY" OFF)
+ CMAKE_DEPENDENT_OPTION(USE_WIIUSE "Support for wiimote input devices" ON
+ "NOT SERVER_ONLY;NOT MINGW;NOT CYGWIN" OFF)
+
+@@ -247,8 +249,10 @@ if(NOT SERVER_ONLY)
+ endif()
+
+ if(NOT SERVER_ONLY)
+- find_library(SQUISH_LIBRARY NAMES squish libsquish)
+- find_path(SQUISH_INCLUDEDIR NAMES squish.h PATHS)
++ if(USE_SYSTEM_SQUISH)
++ find_library(SQUISH_LIBRARY NAMES squish libsquish)
++ find_path(SQUISH_INCLUDEDIR NAMES squish.h PATHS)
++ endif()
+ if (NOT SQUISH_LIBRARY OR NOT SQUISH_INCLUDEDIR)
+ add_subdirectory("${PROJECT_SOURCE_DIR}/lib/libsquish")
+ include_directories("${PROJECT_SOURCE_DIR}/lib/libsquish")
+--
+2.20.1
+