summaryrefslogtreecommitdiff
path: root/games-action/supertuxkart/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
commit623ee73d661e5ed8475cb264511f683407d87365 (patch)
tree993eb27c93ec7a2d2d19550300d888fc1fed9e69 /games-action/supertuxkart/files
parentceeeb463cc1eef97fd62eaee8bf2196ba04bc384 (diff)
gentoo Easter resync : 12.04.2020
Diffstat (limited to 'games-action/supertuxkart/files')
-rw-r--r--games-action/supertuxkart/files/supertuxkart-1.0-system-squish.patch43
-rw-r--r--games-action/supertuxkart/files/supertuxkart-1.1-fix-buildsystem.patch (renamed from games-action/supertuxkart/files/supertuxkart-1.0-fix-buildsystem.patch)8
-rw-r--r--games-action/supertuxkart/files/supertuxkart-1.1-irrlicht-arch-support.patch (renamed from games-action/supertuxkart/files/supertuxkart-0.9.3-irrlicht-arch-support.patch)6
3 files changed, 7 insertions, 50 deletions
diff --git a/games-action/supertuxkart/files/supertuxkart-1.0-system-squish.patch b/games-action/supertuxkart/files/supertuxkart-1.0-system-squish.patch
deleted file mode 100644
index 8158c4bb9e5e..000000000000
--- a/games-action/supertuxkart/files/supertuxkart-1.0-system-squish.patch
+++ /dev/null
@@ -1,43 +0,0 @@
-From e1601b1ae07e3c1ac05cffe05b82e0c60998bc72 Mon Sep 17 00:00:00 2001
-From: James Le Cuirot <chewi@gentoo.org>
-Date: Mon, 13 May 2019 22:51:21 +0100
-Subject: [PATCH] CMake: Add option to use system Squish library
-
-The system version was preferred before but it wasn't possible to
-explicitly disable it, making its use automagic, which is bad for
-packaging.
-
-Closes: https://github.com/supertuxkart/stk-code/pull/3916
----
- CMakeLists.txt | 8 ++++++--
- 1 file changed, 6 insertions(+), 2 deletions(-)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 8a7f03264..40e7790fe 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -31,6 +31,8 @@ CMAKE_DEPENDENT_OPTION(BUILD_RECORDER "Build opengl recorder" ON
- "NOT SERVER_ONLY;NOT APPLE" OFF)
- CMAKE_DEPENDENT_OPTION(USE_FRIBIDI "Support for right-to-left languages" ON
- "NOT SERVER_ONLY" OFF)
-+CMAKE_DEPENDENT_OPTION(USE_SYSTEM_SQUISH "Use system Squish library instead of the built-in version, when available." ON
-+ "NOT SERVER_ONLY" OFF)
- CMAKE_DEPENDENT_OPTION(USE_WIIUSE "Support for wiimote input devices" ON
- "NOT SERVER_ONLY;NOT MINGW;NOT CYGWIN" OFF)
-
-@@ -247,8 +249,10 @@ if(NOT SERVER_ONLY)
- endif()
-
- if(NOT SERVER_ONLY)
-- find_library(SQUISH_LIBRARY NAMES squish libsquish)
-- find_path(SQUISH_INCLUDEDIR NAMES squish.h PATHS)
-+ if(USE_SYSTEM_SQUISH)
-+ find_library(SQUISH_LIBRARY NAMES squish libsquish)
-+ find_path(SQUISH_INCLUDEDIR NAMES squish.h PATHS)
-+ endif()
- if (NOT SQUISH_LIBRARY OR NOT SQUISH_INCLUDEDIR)
- add_subdirectory("${PROJECT_SOURCE_DIR}/lib/libsquish")
- include_directories("${PROJECT_SOURCE_DIR}/lib/libsquish")
---
-2.20.1
-
diff --git a/games-action/supertuxkart/files/supertuxkart-1.0-fix-buildsystem.patch b/games-action/supertuxkart/files/supertuxkart-1.1-fix-buildsystem.patch
index 23e8280a18f4..394a1963199d 100644
--- a/games-action/supertuxkart/files/supertuxkart-1.0-fix-buildsystem.patch
+++ b/games-action/supertuxkart/files/supertuxkart-1.1-fix-buildsystem.patch
@@ -2,13 +2,13 @@ diff --git a/lib/irrlicht/CMakeLists.txt b/lib/irrlicht/CMakeLists.txt
index 92a881c81..1371fdf11 100644
--- a/lib/irrlicht/CMakeLists.txt
+++ b/lib/irrlicht/CMakeLists.txt
-@@ -96,15 +96,6 @@ endif()
+@@ -94,15 +94,6 @@
if(WIN32)
add_definitions(-D_IRR_STATIC_LIB_)
add_definitions(-D_CRT_SECURE_NO_WARNINGS) # Shut up about unsafe stuff
-else()
-- set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wall -pipe -O3 -fno-exceptions -fstrict-aliasing")
-- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wall -pipe -O3 -fno-exceptions -fstrict-aliasing")
+- set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wall -pipe -O3 -fstrict-aliasing")
+- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wall -pipe -O3 -fstrict-aliasing")
- if(CMAKE_COMPILER_IS_GNUCC)
- set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -fexpensive-optimizations")
- endif()
@@ -16,5 +16,5 @@ index 92a881c81..1371fdf11 100644
- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -fexpensive-optimizations")
- endif()
endif()
-
+
if(USE_GLES2)
diff --git a/games-action/supertuxkart/files/supertuxkart-0.9.3-irrlicht-arch-support.patch b/games-action/supertuxkart/files/supertuxkart-1.1-irrlicht-arch-support.patch
index 66191861a963..ad9638ff3dcf 100644
--- a/games-action/supertuxkart/files/supertuxkart-0.9.3-irrlicht-arch-support.patch
+++ b/games-action/supertuxkart/files/supertuxkart-1.1-irrlicht-arch-support.patch
@@ -32,8 +32,8 @@ Signed-off-by: Christoph Egger <debian@christoph-egger.org>
+ #endif
#endif
#define _IRR_POSIX_API_
-@@ -460,11 +464,7 @@
- #undef _IRR_WCHAR_FILESYSTEM
+@@ -465,11 +465,7 @@
+ #undef _IRR_WCHAR_FILESYSTEM
#endif
-#if defined(__sparc__) || defined(__sun__)
@@ -42,6 +42,6 @@ Signed-off-by: Christoph Egger <debian@christoph-egger.org>
-
-#if defined(_IRR_SOLARIS_PLATFORM_)
+#if defined(_IRR_SOLARIS_PLATFORM_) || defined(__FreeBSD_kernel__) || defined(__gnu_hurd__)
- #undef _IRR_COMPILE_WITH_JOYSTICK_EVENTS_
+ #undef _IRR_COMPILE_WITH_JOYSTICK_EVENTS_
#endif