summaryrefslogtreecommitdiff
path: root/games-action/supermariowar
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-12 21:55:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-12 21:55:15 +0000
commit7218e1b46bceac05841e90472501742d905fb3fc (patch)
tree56fae051db521b8fce8014cbc8b11484885b14b3 /games-action/supermariowar
parent6d691ad5b6239929063441bbd14c489e92e7396e (diff)
gentoo resync : 12.03.2021
Diffstat (limited to 'games-action/supermariowar')
-rw-r--r--games-action/supermariowar/Manifest3
-rw-r--r--games-action/supermariowar/files/supermariowar-2.0_beta1-cmake-add_library-static.patch18
-rw-r--r--games-action/supermariowar/supermariowar-2.0_beta1-r1.ebuild88
3 files changed, 62 insertions, 47 deletions
diff --git a/games-action/supermariowar/Manifest b/games-action/supermariowar/Manifest
index c27cbf5c08fe..b9f8750fe2f7 100644
--- a/games-action/supermariowar/Manifest
+++ b/games-action/supermariowar/Manifest
@@ -1,5 +1,6 @@
AUX smwd.initd 902 BLAKE2B 51705ecd466e19f809d9a31dd33a20290fd0aa27832fe52514f1eaffb2ddd89787ff41420614773767c85ade56cccf8bcfb7241d07db47fddbea77c3d94d8b02 SHA512 0c3c9efaa9d239899abf754dee6af71b59f4706e057484502e76abbc0b8ae3a620581c0b3eb7a7ef2f2d050676de46854b033c34d87596b18f195fb7d19495a0
+AUX supermariowar-2.0_beta1-cmake-add_library-static.patch 541 BLAKE2B 5205bfc5e733b2523fd05d859158bff31b41d749bd0177040b60a449ab147d3a4eea85eea7172e635ef707d40845cdf18393fef81dfafa38b67bbd53f0f2d8f0 SHA512 87ecebe43ab12abf748460500a235f88f0b28ec2353aee3b296cbc4bd59b320c08a991fa8ec564526e06c5de4adbfb4bf467fc3f114927262f100b69f0ed974e
AUX supermariowar-2.0_beta1-yaml-cpp-config.cmake 655 BLAKE2B 036aef4603f0cb91de6ece5c5de86fa8fa0e440398e022e4f560764a38030b9fead1ed127b9aebf6a97948660b2c999b20da3791b08691883b7c6e2c80166191 SHA512 a43d28d12962f23a0689533315415597e046bcb09c28a1457d2320da00e376e39939b89839b60e73f368c044ced42b5ccdb909dcdc40a1a345b70fa313ba0bfa
DIST supermariowar-2.0_beta1.tar.gz 13545366 BLAKE2B 497f8d4a8b6e7073c07f2da56e1ace71354fc898660ff866f19ff1d8737e56358eb500d0994dfeeea640dc3ac5aa509be7f31daa75305afc72df8f1497cd5211 SHA512 0849d23ea613d69f32c184dd5f470815a4c68b15836e46e40c30c5a3a6ea2216d4d3305f356e8fdd5b42f4008d9b07f0b9fac84b9f801a4b9f888ba188c56e0b
-EBUILD supermariowar-2.0_beta1-r1.ebuild 2442 BLAKE2B 892359f832d79345eb667a019767a6a2cbd0f2230de136183083ff3b42bf34c310003318c0ab82c201e66e6586ca2606ac00af5133791337b39a0f9b1ba40b07 SHA512 598e5d937dd5099233fa5817f4110e7ff486d4247d55d0b38b0e4bf261351750a5b371f45f0cf9c0949b39271371eb382e9b64954b032f34d144e75c81704ecf
+EBUILD supermariowar-2.0_beta1-r1.ebuild 2361 BLAKE2B d5e3172a564878ebfdc37c84e74890263ad20cbfe268e5b26cfd9497152bcf06515676d4a0dd7948f5a55cede971a5219c89b4e60a871c44773f0468eca5e0d8 SHA512 ec7a4eada56cb0f1deaff81377d5451873c64225e71de1421f410012b79428ba4c26c61ecc7e986ca60bfe0198936d1fed21fb65fab913f538e588cec475b18a
MISC metadata.xml 430 BLAKE2B 020d88a651b04c55427bd67c3ab8efae38575b634ac31ac8b4be8b1527b4f61dd7adb3eb171457fffc83fec10f1a432e280ebce5b25a8a1e32f86a13db3f83fe SHA512 7f7e6599a60ee829ecc2a7db5d956c6ac23b8e213d2e56d8c414a30e1dc7ea5577c080bb79430287ae6df8cae863c99a268fabc0ca2cc06c7d301cc7d9668df1
diff --git a/games-action/supermariowar/files/supermariowar-2.0_beta1-cmake-add_library-static.patch b/games-action/supermariowar/files/supermariowar-2.0_beta1-cmake-add_library-static.patch
new file mode 100644
index 000000000000..2ecc26977598
--- /dev/null
+++ b/games-action/supermariowar/files/supermariowar-2.0_beta1-cmake-add_library-static.patch
@@ -0,0 +1,18 @@
+Fix linking with BUILD_SHARED_LIBS=ON default in EAPI-7
+
+--- a/src/common_netplay/CMakeLists.txt
++++ b/src/common_netplay/CMakeLists.txt
+@@ -1,4 +1,4 @@
+
+ if(NOT NO_NETWORK)
+- add_library(NetplayFiles platform_enet/NetPeerENet.cpp)
++ add_library(NetplayFiles STATIC platform_enet/NetPeerENet.cpp)
+ endif()
+--- a/src/common/CMakeLists.txt
++++ b/src/common/CMakeLists.txt
+@@ -39,4 +39,4 @@
+ list(APPEND COMMON_SRCS src/savepng.cpp)
+ endif()
+
+-add_library(CommonFiles ${COMMON_SRCS})
++add_library(CommonFiles STATIC ${COMMON_SRCS})
diff --git a/games-action/supermariowar/supermariowar-2.0_beta1-r1.ebuild b/games-action/supermariowar/supermariowar-2.0_beta1-r1.ebuild
index 3a70f45083a9..193bd23cf4a5 100644
--- a/games-action/supermariowar/supermariowar-2.0_beta1-r1.ebuild
+++ b/games-action/supermariowar/supermariowar-2.0_beta1-r1.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-inherit eutils cmake-utils versionator
+inherit cmake
-MY_PV=$(replace_version_separator 2 '-')
+MY_PV=$(ver_rs 2 '-')
MY_PV="${MY_PV/beta1/beta.1}"
MY_PN="smw"
@@ -19,91 +19,87 @@ KEYWORDS="amd64 x86"
IUSE="server"
RDEPEND="
- sys-libs/zlib:=
dev-cpp/yaml-cpp
- net-libs/enet:1.3=
media-libs/sdl-mixer[vorbis]
- media-libs/sdl-image[png,jpeg]"
-
-DEPEND="
- ${RDEPEND}
+ media-libs/sdl-image[png,jpeg]
+ net-libs/enet:1.3=
+ sys-libs/zlib:=
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
app-arch/unzip
- virtual/pkgconfig"
+ virtual/pkgconfig
+"
S="${WORKDIR}/${PN}-${MY_PV}"
+PATCHES=( "${FILESDIR}"/${P}-cmake-add_library-static.patch )
+
src_unpack() {
- unpack ${A}
- cd "${S}" || die
+ default
+ pushd "${S}" || die
unpack ./data.zip
-}
-
-src_prepare() {
- cmake-utils_src_prepare
-
- einfo "Copying Findyaml-cpp.cmake"
- cp "${FILESDIR}/${P}-yaml-cpp-config.cmake" cmake/Findyaml-cpp.cmake || die
- eend $?
+ cp "${FILESDIR}"/${P}-yaml-cpp-config.cmake cmake/Findyaml-cpp.cmake || die
+ popd || die
}
src_configure() {
local mycmakeargs=(
-DBUILD_STATIC_LIBS=OFF
- -DSMW_BINDIR="${EPREFIX}/usr/bin"
- -DSMW_DATADIR="${EPREFIX}/usr/share/${PF}"
+ -DSMW_BINDIR="${EPREFIX}"/usr/bin
+ -DSMW_DATADIR="${EPREFIX}"/usr/share/${PF}
)
- cmake-utils_src_configure
+ cmake_src_configure
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
local bin
- for bin in "${ED}/usr/bin"/*; do
- chmod 0755 "${bin}" || die
+ for bin in "${ED}"/usr/bin/*; do
+ chmod 0755 ${bin} || die
done
local smw_datadir="usr/share/${PF}"
local smw_bindir="${smw_datadir}/bin"
- mkdir -p "${ED}/${smw_bindir}" || die
+ mkdir -p "${ED}"/${smw_bindir} || die
- einfo "Moving ${PN} binary files to /${smw_bindir}"
- mv "${ED}/usr/bin"/* "${ED}/${smw_bindir}" || die
+ ebegin "Moving ${PN} binary files to /${smw_bindir}"
+ mv "${ED}"/usr/bin/* "${ED}"/${smw_bindir} || die
eend $?
local base_bin
- for bin in "${ED}/${smw_bindir}"/*; do
- base_bin=$(basename "${bin}")
- einfo "Creating ${base_bin} launcher in /usr/bin"
- cat << EOF > "${base_bin}" || die
+ for bin in "${ED}"/${smw_bindir}/*; do
+ base_bin=$(basename ${bin})
+ ebegin "Creating ${base_bin} launcher in /usr/bin"
+ cat << EOF > ${base_bin} || die
#!/usr/bin/env bash
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
# ${PF} launcher: ${base_bin}
exec /${smw_bindir}/${base_bin} /${smw_datadir}
EOF
- dobin "${base_bin}"
+ dobin ${base_bin}
eend $?
done
if use server; then
- local smw_server="${BUILD_DIR}/Binaries/Release/${MY_PN}-server"
+ local smw_server="${BUILD_DIR}"/Binaries/Release/${MY_PN}-server
local smw_serverdir="/${smw_datadir}/server"
- einfo "Installing ${MY_PN}-server files"
+ ebegin "Installing ${MY_PN}-server files"
dosbin "${smw_server}"
- dodir "${smw_serverdir}"
- insinto "${smw_serverdir}"
- doins "${S}/src/server/serverconfig"
+ dodir ${smw_serverdir}
+ insinto ${smw_serverdir}
+ doins "${S}"/src/server/serverconfig
- dosym "${smw_serverdir}/serverconfig" "/etc/${MY_PN}d.conf"
+ dosym ${smw_serverdir}/serverconfig /etc/${MY_PN}d.conf
- newinitd "${FILESDIR}/smwd.initd" "${MY_PN}d"
- sed -i -e \
- "s#@SMW_SERVERDIR@#${smw_serverdir}#g;" \
- "${ED}/etc/init.d/${MY_PN}d" || die
+ newinitd "${FILESDIR}"/smwd.initd ${MY_PN}d
+ sed -e "s#@SMW_SERVERDIR@#${smw_serverdir}#g;" \
+ -i "${ED}"/etc/init.d/${MY_PN}d || die
eend $?
fi
}