summaryrefslogtreecommitdiff
path: root/games-action/snipes/snipes-1.0.4-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-09-16 22:05:01 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-09-16 22:05:01 +0100
commitcc4618c9ba3d974948ebf340b542d8cb01db2f55 (patch)
tree125ee67bb9e0d548771cf7b61d04bb1f0dc57687 /games-action/snipes/snipes-1.0.4-r1.ebuild
parent677b7ba5c317778df2ad7e70df94b9b7eec4adbc (diff)
gentoo resync : 16.09.2021
Diffstat (limited to 'games-action/snipes/snipes-1.0.4-r1.ebuild')
-rw-r--r--games-action/snipes/snipes-1.0.4-r1.ebuild33
1 files changed, 19 insertions, 14 deletions
diff --git a/games-action/snipes/snipes-1.0.4-r1.ebuild b/games-action/snipes/snipes-1.0.4-r1.ebuild
index 666172514c64..6b6beac3a3a4 100644
--- a/games-action/snipes/snipes-1.0.4-r1.ebuild
+++ b/games-action/snipes/snipes-1.0.4-r1.ebuild
@@ -1,35 +1,40 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
-inherit desktop toolchain-funcs
+inherit desktop flag-o-matic toolchain-funcs
DESCRIPTION="2D scrolling shooter, resembles the old DOS game of same name"
-HOMEPAGE="https://cyp.github.com/snipes/"
-SRC_URI="https://cyp.github.com/snipes/${P}.tar.gz"
+HOMEPAGE="https://wiki.gentoo.org/wiki/No_homepage"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
-LICENSE="GPL-2"
+LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
-DEPEND="media-libs/libsdl[sound,video]"
-RDEPEND=${DEPEND}
+RDEPEND="media-libs/libsdl[sound,video]"
+DEPEND="${RDEPEND}"
PATCHES=(
- "${FILESDIR}"/${P}-nongnulinker.patch
+ "${FILESDIR}"/${P}-ldflags.patch
)
src_compile() {
- tc-getLD
- default
+ tc-export CC LD
+
+ # lld requires arch flags to be passed even if native (bug #730852)
+ local archflags=
+ tc-ld-is-lld && eval archflags=\${LDFLAGS_${ARCH}}
+
+ LDLIBS=-lm emake RAW_LDFLAGS="${archflags} $(raw-ldflags)"
}
src_install() {
dobin snipes
doman snipes.6
- dodoc ChangeLog
+ einstalldocs
+
doicon ${PN}.png
- make_desktop_entry snipes "Snipes"
+ make_desktop_entry ${PN} ${PN^}
}