summaryrefslogtreecommitdiff
path: root/games-action/slune
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-action/slune
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-action/slune')
-rw-r--r--games-action/slune/Manifest3
-rw-r--r--games-action/slune/metadata.xml8
-rw-r--r--games-action/slune/slune-1.0.15-r1.ebuild75
3 files changed, 86 insertions, 0 deletions
diff --git a/games-action/slune/Manifest b/games-action/slune/Manifest
new file mode 100644
index 000000000000..8cfbf797dee7
--- /dev/null
+++ b/games-action/slune/Manifest
@@ -0,0 +1,3 @@
+DIST Slune-1.0.15.tar.bz2 9549694 BLAKE2B 2178f5bc5f111cc408a7e1391e87bca1a9bd934668c2519b604a9aecc889a560e9bd576e70d1738f51fb9afd9450f47e331c3c036258b6223ed059546d12ee31 SHA512 7f26f91a7db5ccfd2b7063592c53a0b5791f5db5dee582c0f2208af7615c3b7f0b1ed420ecef1f1396a6b1573cb99cc40e886bc47bc22d064bc3ad4814421920
+EBUILD slune-1.0.15-r1.ebuild 1533 BLAKE2B 86194282f7ab45cfc7ed86ca936284bfb267223d3deeefdab3e6730f1f9336680b9bd1a0891afe448c77151fb5dd8e5cdd3c66b7e44eba4596ef55a1923770b1 SHA512 2d37508d9f997c5eb281ebe0af3c80c34146360d91eefb9bc987c4a982e541c9a9802c97a1847bbcb9a2d6e4c9ec0647f452f9361947438da9964cc9987016f5
+MISC metadata.xml 249 BLAKE2B 7113a758d7abc93accec998a8843d8ef51ca8b72d72e659e224d5cec2a1a6a63e6c0605958091532ac6e51fa0d501ca4fd9f3f4a9e55baeb31519a02971b465f SHA512 895577c3a805c40581da03057b94e3f28f05f23012bf350c1e3575847d1a0fe40bb044a46f909012a200d991a400f6389358a60e9c2b5bef0da01fb26f846118
diff --git a/games-action/slune/metadata.xml b/games-action/slune/metadata.xml
new file mode 100644
index 000000000000..78274e0fa550
--- /dev/null
+++ b/games-action/slune/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+</maintainer>
+</pkgmetadata>
diff --git a/games-action/slune/slune-1.0.15-r1.ebuild b/games-action/slune/slune-1.0.15-r1.ebuild
new file mode 100644
index 000000000000..a6e9ecaf1c09
--- /dev/null
+++ b/games-action/slune/slune-1.0.15-r1.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit gnome2-utils python-utils-r1 distutils-r1 games
+
+DESCRIPTION="A 3D action game with multiplayer mode and amazing graphics"
+HOMEPAGE="http://oomadness.tuxfamily.org/en/slune/"
+SRC_URI="http://download.gna.org/slune/Slune-${PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="virtual/opengl
+ >=media-libs/libsdl-1.2.6
+ >=dev-python/soya-0.9
+ >=dev-python/py2play-0.1.9
+ >=dev-python/pyopenal-0.1.3
+ >=dev-python/pyogg-1.1
+ >=dev-python/pyvorbis-1.1"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/Slune-${PV}
+
+python_install() {
+ distutils-r1_python_install \
+ --install-scripts="${GAMES_BINDIR}" \
+ --install-data="${GAMES_DATADIR}" \
+ --install-lib="$(python_get_sitedir)"
+
+ # FHS broke the logic, fix it
+ local i
+ for i in $(ls -I locale "${ED}${GAMES_DATADIR}"/${PN}) ; do
+ dosym "${GAMES_DATADIR}/${PN}/${i}" "$(python_get_sitedir)/${PN}/${i}"
+ done
+}
+
+src_prepare() {
+ distutils-r1_src_prepare
+}
+
+src_compile() {
+ distutils-r1_src_compile
+}
+
+src_install() {
+ distutils-r1_src_install
+
+ # fix install dest of locales
+ mv "${ED}${GAMES_DATADIR}"/${PN}/locale "${ED}"/usr/share/locale || die
+
+ newicon -s 48 images/${PN}.48.png ${PN}.png
+ make_desktop_entry ${PN} "Slune"
+
+ prepgamesdirs
+}
+
+pkg_preinst() {
+ games_pkg_preinst
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}