summaryrefslogtreecommitdiff
path: root/games-action/shootingstar/shootingstar-1.2.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /games-action/shootingstar/shootingstar-1.2.0-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'games-action/shootingstar/shootingstar-1.2.0-r1.ebuild')
-rw-r--r--games-action/shootingstar/shootingstar-1.2.0-r1.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/games-action/shootingstar/shootingstar-1.2.0-r1.ebuild b/games-action/shootingstar/shootingstar-1.2.0-r1.ebuild
new file mode 100644
index 000000000000..11411f402d59
--- /dev/null
+++ b/games-action/shootingstar/shootingstar-1.2.0-r1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools eutils gnome2-utils
+
+# Note: currently segfaults on startup, but that's also in the previous ebuild
+# See https://bugs.gentoo.org/607428
+
+DESCRIPTION="A topdown shooter"
+HOMEPAGE="http://linux.softpedia.com/get/GAMES-ENTERTAINMENT/Arcade/Shooting-Star-19754.shtml"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ media-libs/libsdl[video]
+ media-libs/sdl-image
+ media-libs/sdl-mixer
+ virtual/glu
+ virtual/opengl"
+RDEPEND=${DEPEND}
+
+PATCHES=(
+ "${FILESDIR}"/${PV}-gcc34.patch
+ "${FILESDIR}"/${P}-gcc44.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_install () {
+ default
+ newicon -s 128 data/textures/body1.png ${PN}.png
+ make_desktop_entry ${PN} "Shooting Star"
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}