summaryrefslogtreecommitdiff
path: root/games-action/openastromenace/openastromenace-1.3.2-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:58:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:58:29 +0100
commit0cf2f20608308acdf3cb922c3736446bbd8f3388 (patch)
tree07815070629c7c11000a7f51ceb8ccbccb49a809 /games-action/openastromenace/openastromenace-1.3.2-r1.ebuild
parent1798c4aeca70ac8d0a243684d6a798fbc65735f8 (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-action/openastromenace/openastromenace-1.3.2-r1.ebuild')
-rw-r--r--games-action/openastromenace/openastromenace-1.3.2-r1.ebuild75
1 files changed, 0 insertions, 75 deletions
diff --git a/games-action/openastromenace/openastromenace-1.3.2-r1.ebuild b/games-action/openastromenace/openastromenace-1.3.2-r1.ebuild
deleted file mode 100644
index cdd657e1958c..000000000000
--- a/games-action/openastromenace/openastromenace-1.3.2-r1.ebuild
+++ /dev/null
@@ -1,75 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit gnome2-utils cmake-utils eutils
-
-DESCRIPTION="Modern 3D space shooter with spaceship upgrade possibilities"
-HOMEPAGE="https://sourceforge.net/projects/openastromenace/"
-SRC_URI="mirror://sourceforge/openastromenace/${PV}/astromenace-src-${PV}.tar.bz2"
-
-LICENSE="GPL-3 GPL-3+ CC-BY-SA-3.0 UbuntuFontLicense-1.0 OFL-1.1"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-DEPEND="
- media-libs/freealut
- media-libs/freetype:2
- media-libs/libogg
- media-libs/libsdl[joystick,video,X]
- media-libs/libvorbis
- media-libs/openal
- virtual/glu
- virtual/opengl
- x11-libs/libXinerama"
-RDEPEND=${DEPEND}
-
-S=${WORKDIR}/AstroMenace
-
-src_prepare() {
- cmake-utils_src_prepare
-
- # no messing with CXXFLAGS please.
- sed -i -e '/-Os/d' CMakeLists.txt || die
-}
-
-src_configure() {
- local mycmakeargs=("-DDATADIR=/usr/share/${PN}")
-
- cmake-utils_src_configure
-}
-
-src_compile() {
- cmake-utils_src_compile
-
- "${CMAKE_BUILD_DIR}"/AstroMenace --pack \
- --rawdata="${S}"/RAW_VFS_DATA \
- --dir=$(dirname "${CMAKE_BUILD_DIR}") || die
-}
-
-src_install() {
- newbin "${CMAKE_BUILD_DIR}"/AstroMenace "${PN}"
-
- insinto /usr/share/${PN}
- doins ../*.vfs
-
- newicon -s 128 astromenace_128.png ${PN}.png
- newicon -s 64 astromenace_64.png ${PN}.png
-
- dodoc ChangeLog.txt ReadMe.txt
-
- make_desktop_entry "${PN}" OpenAstroMenace
-}
-
-pkg_preinst() {
- gnome2_icon_savelist
-}
-
-pkg_postinst() {
- gnome2_icon_cache_update
-}
-
-pkg_postrm() {
- gnome2_icon_cache_update
-}