summaryrefslogtreecommitdiff
path: root/games-action/minetest/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
commitfcc5224904648a8e6eb528d7603154160a20022f (patch)
tree3bfce096b38a9cea8eed13fc70c1526c456e9abd /games-action/minetest/files
parent2fd57282f0262ca084e05b0f2c63fbada395d02b (diff)
gentoo resync : 02.02.2022
Diffstat (limited to 'games-action/minetest/files')
-rw-r--r--games-action/minetest/files/minetest-5.5.0-bundled_luabitop.patch17
1 files changed, 17 insertions, 0 deletions
diff --git a/games-action/minetest/files/minetest-5.5.0-bundled_luabitop.patch b/games-action/minetest/files/minetest-5.5.0-bundled_luabitop.patch
new file mode 100644
index 000000000000..5006ddd499b6
--- /dev/null
+++ b/games-action/minetest/files/minetest-5.5.0-bundled_luabitop.patch
@@ -0,0 +1,17 @@
+When built against PUC Lua, minetest binaries get linked against
+a customised version of LuaBitOp which then gets installed
+as /usr/$(get_libdir)/libbitop.so. This violates the policies of both
+Gentoo (unversioned shared library) and Lua itself (compiled extensions
+should be installed into implementation-specific directories rather than
+top-level libdir, and I'm pretty sure linking against such extensions
+is a no-no). Switching to system dev-lua/LuaBitOp will require work
+so just make the customised version static for now.
+
+--- a/lib/bitop/CMakeLists.txt
++++ b/lib/bitop/CMakeLists.txt
+@@ -1,4 +1,4 @@
+-add_library(bitop bit.c)
++add_library(bitop STATIC bit.c)
+ target_link_libraries(bitop)
+
+ include_directories(${LUA_INCLUDE_DIR})