summaryrefslogtreecommitdiff
path: root/games-action/koth
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-action/koth
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-action/koth')
-rw-r--r--games-action/koth/Manifest4
-rw-r--r--games-action/koth/files/koth-0.8.0-r1-gcc-3.4.patch29
-rw-r--r--games-action/koth/koth-0.8.0-r1.ebuild36
-rw-r--r--games-action/koth/metadata.xml11
4 files changed, 80 insertions, 0 deletions
diff --git a/games-action/koth/Manifest b/games-action/koth/Manifest
new file mode 100644
index 000000000000..623a9303fe98
--- /dev/null
+++ b/games-action/koth/Manifest
@@ -0,0 +1,4 @@
+AUX koth-0.8.0-r1-gcc-3.4.patch 628 BLAKE2B e62daab926595507618cc9215612bd11bd901218448cf2a192023ddbd4c13fce70a49f853a50df628adb12c077cd6597b22cbafb67e1ca42394d90defbab6676 SHA512 ca6bfe40d9ab0a08bae833684628422d2b69047ec4aa80df43e0c093184680f8d202180f0ae3d89099b4c45aa481ac28055a1a5deb5afb69e8c397508e46e08e
+DIST koth-0.8.0.tar.bz2 140569 BLAKE2B cfcbba838238fbe45bccc800c258290531341623d4a57825f389a01278febe3b99d9459f4294cea9f4520c0dc76ad945266640c89687ab0b77a5348d2b88685a SHA512 edda377be9074298c63e85cad5f37f55dc67f0e9a7d075a94207559265ffbf8a5eadbd2dc0e4a06e535e6da9fcfd309d01141ba8be04cf8960b0229e0ce4ab9f
+EBUILD koth-0.8.0-r1.ebuild 838 BLAKE2B 52adb1c2da3b9eb6e276e699de9500b5bb296a080923da98cae63a474cf3e7758a8344cb80452dd06fcf0e4dad11937a3b31bc6aaf636590dba87dabed9ab1b4 SHA512 bb5092995841a66257753e845bf53dd3fff8b7de23f809bacdab94189d9ec753be52763c5f235661e15b3a460d435d64ae59e2bb7b6fcda2413de1e2ca0f64a2
+MISC metadata.xml 562 BLAKE2B f5d44dfcf5ed0fa77163ea4ac24d010fe3236130fb0dce1c68b8cb5804e6a5cd088a3b0d14bc573279ed23165d829a2f49516123e57158fd054469271bb20bd5 SHA512 c9bf2b0f6d97e56b9b8d3667fecd9a18bc971f2a396c7bb9a2904ea3e86eec4b625ff73630b4c6a45eea30418e8cfd8b3774a699e45b98b4e44bbb205365d333
diff --git a/games-action/koth/files/koth-0.8.0-r1-gcc-3.4.patch b/games-action/koth/files/koth-0.8.0-r1-gcc-3.4.patch
new file mode 100644
index 000000000000..145f17dbccdd
--- /dev/null
+++ b/games-action/koth/files/koth-0.8.0-r1-gcc-3.4.patch
@@ -0,0 +1,29 @@
+--- a/src/relay.c 2004-11-01 09:19:04.835537536 +0000
++++ b/src/relay.c 2004-11-01 09:19:59.453234384 +0000
+@@ -260,6 +260,7 @@
+ else goto bail;
+ goto nextpkt;
+ bail:
++ ;
+ }
+ }
+ }
+--- a/src/ballistics.c 2004-11-01 09:19:33.132235784 +0000
++++ b/src/ballistics.c 2004-11-01 09:20:16.849589736 +0000
+@@ -92,6 +92,7 @@
+ break;
+ case WALL_LAST:
+ /* just to satisfy gcc -Wall */
++ ;
+ }
+ }
+
+@@ -210,7 +211,7 @@
+ break;
+ case WALL_RANDOM: /* both of this can't happen, */
+ case WALL_LAST: /* so they are here to satisfy gcc -Wall */
+-
++ ;
+ }
+ }
+ return FLYING;
diff --git a/games-action/koth/koth-0.8.0-r1.ebuild b/games-action/koth/koth-0.8.0-r1.ebuild
new file mode 100644
index 000000000000..bc77fea14053
--- /dev/null
+++ b/games-action/koth/koth-0.8.0-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit eutils flag-o-matic
+
+DESCRIPTION="Multiplayer, networked game of little tanks with really big weapons"
+HOMEPAGE="http://www.nongnu.org/koth/"
+SRC_URI="https://savannah.nongnu.org/download/${PN}/default.pkg/${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND="media-libs/libggi"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PF}-gcc-3.4.patch
+)
+
+src_prepare() {
+ default
+ sed -i 's:-g -O2::' configure || die
+ sed -i 's:(uint16):(uint16_t):' src/gfx.c src/gfx.h || die
+ append-cflags -std=gnu89 # build with gcc5 (bug #570730)
+}
+
+src_install() {
+ DOCS="AUTHORS ChangeLog NEWS README doc/*.txt" \
+ default
+ dodir /etc/koth
+ insinto /etc/koth
+ doins src/koth.cfg
+}
diff --git a/games-action/koth/metadata.xml b/games-action/koth/metadata.xml
new file mode 100644
index 000000000000..af8d2cdcfd9e
--- /dev/null
+++ b/games-action/koth/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+</maintainer>
+<longdescription>
+King of the Hill (KOTH) is a multiplayer, networked artillery game of little tanks with really big weapons set out to destroy one another. Best-known games of this type include the classic DOS game "Scorched Earth: The Mother of All Games" and "Scorched Tanks" for the Amiga.
+</longdescription>
+</pkgmetadata>