summaryrefslogtreecommitdiff
path: root/games-action/koth/koth-0.8.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /games-action/koth/koth-0.8.0-r1.ebuild
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'games-action/koth/koth-0.8.0-r1.ebuild')
-rw-r--r--games-action/koth/koth-0.8.0-r1.ebuild22
1 files changed, 11 insertions, 11 deletions
diff --git a/games-action/koth/koth-0.8.0-r1.ebuild b/games-action/koth/koth-0.8.0-r1.ebuild
index 988f9bf485dc..3030dcd88d94 100644
--- a/games-action/koth/koth-0.8.0-r1.ebuild
+++ b/games-action/koth/koth-0.8.0-r1.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-inherit eutils flag-o-matic
+EAPI=7
+
+inherit autotools
DESCRIPTION="Multiplayer, networked game of little tanks with really big weapons"
HOMEPAGE="http://www.nongnu.org/koth/"
@@ -11,26 +12,25 @@ SRC_URI="https://savannah.nongnu.org/download/${PN}/default.pkg/${PV}/${P}.tar.b
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~x86"
-IUSE=""
DEPEND="media-libs/libggi"
RDEPEND="${DEPEND}"
PATCHES=(
- "${FILESDIR}"/${PF}-gcc-3.4.patch
+ "${FILESDIR}"/${P}-autotools.patch
+ "${FILESDIR}"/${P}-gcc.patch
)
src_prepare() {
default
- sed -i 's:-g -O2::' configure || die
- sed -i 's:(uint16):(uint16_t):' src/gfx.c src/gfx.h || die
- append-cflags -std=gnu89 # build with gcc5 (bug #570730)
+ mv configure.{in,ac} || die
+ eautoreconf
}
src_install() {
- DOCS="AUTHORS ChangeLog NEWS README doc/*.txt" \
- default
- dodir /etc/koth
+ default
+ dodoc doc/*.txt
+
insinto /etc/koth
doins src/koth.cfg
}