summaryrefslogtreecommitdiff
path: root/games-action/heroes/heroes-0.21-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:58:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:58:29 +0100
commit0cf2f20608308acdf3cb922c3736446bbd8f3388 (patch)
tree07815070629c7c11000a7f51ceb8ccbccb49a809 /games-action/heroes/heroes-0.21-r2.ebuild
parent1798c4aeca70ac8d0a243684d6a798fbc65735f8 (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-action/heroes/heroes-0.21-r2.ebuild')
-rw-r--r--games-action/heroes/heroes-0.21-r2.ebuild73
1 files changed, 0 insertions, 73 deletions
diff --git a/games-action/heroes/heroes-0.21-r2.ebuild b/games-action/heroes/heroes-0.21-r2.ebuild
deleted file mode 100644
index 5ab9018ee3d1..000000000000
--- a/games-action/heroes/heroes-0.21-r2.ebuild
+++ /dev/null
@@ -1,73 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit eutils autotools
-
-data_ver=1.5
-snd_trk_ver=1.0
-snd_eff_ver=1.0
-
-DESCRIPTION="Heroes Enjoy Riding Over Empty Slabs: similar to Tron and Nibbles"
-HOMEPAGE="http://heroes.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2
- mirror://sourceforge/${PN}/${PN}-data-${data_ver}.tar.bz2
- mirror://sourceforge/${PN}/${PN}-sound-tracks-${snd_trk_ver}.tar.bz2
- mirror://sourceforge/${PN}/${PN}-sound-effects-${snd_eff_ver}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="ggi nls sdl"
-RESTRICT="test"
-
-RDEPEND="
- ggi? ( media-libs/libggi media-libs/libgii media-libs/libmikmod )
- nls? ( virtual/libintl )
- sdl? ( media-libs/libsdl media-libs/sdl-mixer )
- !sdl? ( !ggi? ( media-libs/libsdl media-libs/sdl-mixer ) )"
-DEPEND="${RDEPEND}
- nls? ( sys-devel/gettext )"
-
- #56118
-PATCHES=(
- "${FILESDIR}/${P}"-automake-1.12.patch
- "${FILESDIR}/${P}"-gcc4.patch
- "${FILESDIR}/${P}"-underlink.patch
- "${FILESDIR}/${PV}"-cvs-segfault-fix.patch
-)
-
-src_prepare() {
- default
- sed -i 's:$(localedir):/usr/share/locale:' \
- $(find . -name 'Makefile.in*') || die
- eautoreconf
-}
-
-src_configure() {
- local myconf
-
- if use sdl || ! use ggi ; then
- myconf="${myconf} --with-sdl --with-sdl-mixer"
- else
- myconf="${myconf} --with-ggi --with-mikmod"
- fi
-
- local pkg
- for pkg in ${A//.tar.bz2} ; do
- cd "${WORKDIR}"/${pkg}
- econf \
- --disable-heroes-debug \
- --disable-optimizations \
- $(use_enable nls) \
- ${myconf}
- done
-}
-
-src_install() {
- local pkg
- for pkg in ${A//.tar.bz2} ; do
- cd "${WORKDIR}"/${pkg}
- emake DESTDIR="${D}" install
- done
-}