summaryrefslogtreecommitdiff
path: root/games-action/clanbomber/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-action/clanbomber/files
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-action/clanbomber/files')
-rw-r--r--games-action/clanbomber/files/clanbomber-2.1.1-automake112.patch11
-rw-r--r--games-action/clanbomber/files/clanbomber-2.1.1-boost150.patch31
-rw-r--r--games-action/clanbomber/files/clanbomber-2.1.1-gcc6.patch19
3 files changed, 61 insertions, 0 deletions
diff --git a/games-action/clanbomber/files/clanbomber-2.1.1-automake112.patch b/games-action/clanbomber/files/clanbomber-2.1.1-automake112.patch
new file mode 100644
index 000000000000..5fce5be335aa
--- /dev/null
+++ b/games-action/clanbomber/files/clanbomber-2.1.1-automake112.patch
@@ -0,0 +1,11 @@
+--- a/configure.ac 2012-11-15 09:35:24.682199511 +0100
++++ b/configure.ac 2012-11-15 09:36:02.367839076 +0100
+@@ -2,7 +2,7 @@
+ AC_PREREQ([2.63])
+ AC_INIT([ClanBomber], [2.1.1], [rsl@members.fsf.org])
+ #AM_INIT_AUTOMAKE([-Wall -Werror foreign])#foreign is for NEWS COPYING ETC
+-AM_INIT_AUTOMAKE([dist-lzma -Wall -Werror])
++AM_INIT_AUTOMAKE([-Wall])
+
+
+ #CXXFLAGS="-O6 -g3"
diff --git a/games-action/clanbomber/files/clanbomber-2.1.1-boost150.patch b/games-action/clanbomber/files/clanbomber-2.1.1-boost150.patch
new file mode 100644
index 000000000000..f3e67666a22d
--- /dev/null
+++ b/games-action/clanbomber/files/clanbomber-2.1.1-boost150.patch
@@ -0,0 +1,31 @@
+--- a/src/MapEntry.cpp 2012-11-15 10:55:40.123259605 +0100
++++ b/src/MapEntry.cpp 2012-11-15 10:57:35.217379211 +0100
+@@ -50,7 +50,7 @@
+ enabled = true;
+
+ // extract map name
+- map_name = filename.stem();
++ map_name = filename.stem().string();
+
+ // is the file writable?
+ if (access(path / filename, W_OK) == 0) {
+--- a/src/Map.cpp 2012-11-15 10:52:56.884424228 +0100
++++ b/src/Map.cpp 2012-11-15 10:54:16.334992079 +0100
+@@ -116,7 +116,7 @@
+ for (boost::filesystem::directory_iterator dir_iter(path);
+ dir_iter != end_iter; dir_iter++) {
+ if (dir_iter->path().extension() == ".map") {
+- map_list.push_back(new MapEntry(path, dir_iter->filename()));
++ map_list.push_back(new MapEntry(path, dir_iter->path().filename()));
+ }
+ }
+ }
+@@ -126,7 +126,7 @@
+ for (boost::filesystem::directory_iterator dir_iter(path);
+ dir_iter != end_iter; dir_iter++) {
+ if (dir_iter->path().extension() == ".map") {
+- map_list.push_back(new MapEntry(path, dir_iter->filename()));
++ map_list.push_back(new MapEntry(path, dir_iter->path().filename()));
+ }
+ }
+ }
diff --git a/games-action/clanbomber/files/clanbomber-2.1.1-gcc6.patch b/games-action/clanbomber/files/clanbomber-2.1.1-gcc6.patch
new file mode 100644
index 000000000000..714e9de85fa2
--- /dev/null
+++ b/games-action/clanbomber/files/clanbomber-2.1.1-gcc6.patch
@@ -0,0 +1,19 @@
+--- a/src/Credits.h
++++ b/src/Credits.h
+@@ -47,7 +47,7 @@
+ int speed;
+ bool stopped;
+ private:
+- static const float yoffset_start = 50;
++ static const float yoffset_start;
+ static const int normal_speed = 40;
+ static const int text_height = 40;
+
+--- a/src/Credits.cpp
++++ b/src/Credits.cpp
+@@ -273,3 +273,5 @@
+ (*draw_list_iter)->show();
+ }
+ }
++
++const float Credits::yoffset_start = 50;