summaryrefslogtreecommitdiff
path: root/games-action/bzflag/bzflag-2.4.14.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-05-04 11:22:40 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-05-04 11:22:40 +0100
commitfe1c8b732bd548b699d4c2ef725f67f8b8c8911c (patch)
tree84c0b6ca01b7cb63c7d6e685a63823200ce1007f /games-action/bzflag/bzflag-2.4.14.ebuild
parent7c7c2c9727d6b2ff30945b5aea0d575e1c406d8b (diff)
gentoo resync : 04.05.2018
Diffstat (limited to 'games-action/bzflag/bzflag-2.4.14.ebuild')
-rw-r--r--games-action/bzflag/bzflag-2.4.14.ebuild62
1 files changed, 62 insertions, 0 deletions
diff --git a/games-action/bzflag/bzflag-2.4.14.ebuild b/games-action/bzflag/bzflag-2.4.14.ebuild
new file mode 100644
index 000000000000..cf647d42a263
--- /dev/null
+++ b/games-action/bzflag/bzflag-2.4.14.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit eutils flag-o-matic autotools
+
+DESCRIPTION="3D tank combat simulator game"
+HOMEPAGE="https://www.bzflag.org/"
+SRC_URI="https://download.bzflag.org/bzflag/source/${PV}/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="dedicated upnp"
+
+DEPEND="
+ net-dns/c-ares
+ >=net-misc/curl-7.15.0
+ sys-libs/ncurses:0
+ sys-libs/zlib
+ !dedicated? (
+ media-libs/libsdl2[joystick,sound,video]
+ virtual/glu
+ virtual/opengl )
+ upnp? ( net-libs/miniupnpc )"
+RDEPEND=${DEPEND}
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.4.12-configure.patch
+ "${FILESDIR}"/${PN}-2.4.12-tinfo.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myconf
+
+ if use dedicated ; then
+ ewarn
+ ewarn "You are building a server-only copy of BZFlag"
+ ewarn
+ myconf="--disable-client --without-SDL"
+ fi
+
+ econf \
+ $(use_enable upnp UPnP) \
+ ${myconf}
+}
+
+src_install() {
+ DOCS="AUTHORS ChangeLog DEVINFO PORTING README README.Linux" \
+ default
+
+ if ! use dedicated ; then
+ newicon data/bzflag-48x48.png ${PN}.png
+ make_desktop_entry ${PN} "BZFlag"
+ fi
+
+ prune_libtool_files --modules
+}