summaryrefslogtreecommitdiff
path: root/games-action/bzflag/bzflag-2.4.14.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-08-25 07:36:27 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-08-25 07:36:27 +0100
commit43793fab84041cfc5c60c0151d1591b8a69fb24a (patch)
tree6208a7f4fc744684fce0f55acbb47511acace498 /games-action/bzflag/bzflag-2.4.14.ebuild
parent28e3d252dc8ac8a5635206dfefe1cfe05058d1db (diff)
gentoo resync : 25.08.2018
Diffstat (limited to 'games-action/bzflag/bzflag-2.4.14.ebuild')
-rw-r--r--games-action/bzflag/bzflag-2.4.14.ebuild16
1 files changed, 8 insertions, 8 deletions
diff --git a/games-action/bzflag/bzflag-2.4.14.ebuild b/games-action/bzflag/bzflag-2.4.14.ebuild
index 290ef54d300a..68787097d150 100644
--- a/games-action/bzflag/bzflag-2.4.14.ebuild
+++ b/games-action/bzflag/bzflag-2.4.14.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-inherit eutils flag-o-matic autotools
+inherit autotools desktop flag-o-matic ltprune
DESCRIPTION="3D tank combat simulator game"
HOMEPAGE="https://www.bzflag.org/"
@@ -40,21 +40,21 @@ src_prepare() {
}
src_configure() {
- local myconf
+ local myconf=(
+ $(use_enable upnp UPnP)
+ --libdir="${EPREFIX}"/usr/$(get_libdir)/${PN}
+ )
if use dedicated ; then
ewarn
ewarn "You are building a server-only copy of BZFlag"
ewarn
- myconf="--disable-client --without-SDL"
+ myconf+=( --disable-client --without-SDL )
else
- myconf="--with-SDL=2"
+ myconf=( --with-SDL=2 )
fi
- econf \
- $(use_enable upnp UPnP) \
- --libdir=/usr/$(get_libdir)/${PN} \
- ${myconf}
+ econf "${myconf[@]}"
}
src_install() {