summaryrefslogtreecommitdiff
path: root/eclass
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-03-12 06:46:08 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-03-12 06:46:08 +0000
commitc6e62298405d39e635c0d8dd6e026c8cb667a478 (patch)
tree797bd877e6cc2cdcfe3e39ecfedf34781075fc86 /eclass
parent2c3b9bbdb114cc13b6ef8e0e5933c9e374fca8b6 (diff)
gentoo auto-resync : 12:03:2024 - 06:46:08
Diffstat (limited to 'eclass')
-rw-r--r--eclass/Manifest.gzbin39614 -> 39625 bytes
-rw-r--r--eclass/distutils-r1.eclass42
-rw-r--r--eclass/linux-info.eclass16
-rw-r--r--eclass/toolchain.eclass3
4 files changed, 32 insertions, 29 deletions
diff --git a/eclass/Manifest.gz b/eclass/Manifest.gz
index 05373e275bdc..8490f9f0702c 100644
--- a/eclass/Manifest.gz
+++ b/eclass/Manifest.gz
Binary files differ
diff --git a/eclass/distutils-r1.eclass b/eclass/distutils-r1.eclass
index e0c54d81a846..9be994595529 100644
--- a/eclass/distutils-r1.eclass
+++ b/eclass/distutils-r1.eclass
@@ -1505,32 +1505,28 @@ distutils-r1_python_compile() {
_python_check_EPYTHON
- case ${DISTUTILS_USE_PEP517:-setuptools} in
- setuptools)
- # call setup.py build when using setuptools (either via PEP517
- # or in legacy mode)
-
- # distutils is parallel-capable since py3.5
- local jobs=$(makeopts_jobs "${MAKEOPTS} ${*}")
-
- if [[ ${DISTUTILS_USE_PEP517} ]]; then
- mkdir -p "${BUILD_DIR}" || die
- local -x DIST_EXTRA_CONFIG="${BUILD_DIR}/extra-setup.cfg"
- cat > "${DIST_EXTRA_CONFIG}" <<-EOF || die
- [build]
- build_base = ${BUILD_DIR}/build
-
- [build_ext]
- parallel = ${jobs}
- EOF
- else
- _distutils-r1_copy_egg_info
- esetup.py build -j "${jobs}" "${@}"
- fi
- ;;
+ case ${DISTUTILS_USE_PEP517:-unset} in
no)
return
;;
+ unset)
+ # legacy mode
+ _distutils-r1_copy_egg_info
+ esetup.py build -j "$(makeopts_jobs "${MAKEOPTS} ${*}")" "${@}"
+ ;;
+ *)
+ # we do this for all build systems, since other backends
+ # and custom hooks may wrap setuptools
+ mkdir -p "${BUILD_DIR}" || die
+ local -x DIST_EXTRA_CONFIG="${BUILD_DIR}/extra-setup.cfg"
+ cat > "${DIST_EXTRA_CONFIG}" <<-EOF || die
+ [build]
+ build_base = ${BUILD_DIR}/build
+
+ [build_ext]
+ parallel = $(makeopts_jobs "${MAKEOPTS} ${*}")
+ EOF
+ ;;
esac
if [[ ${DISTUTILS_USE_PEP517} ]]; then
diff --git a/eclass/linux-info.eclass b/eclass/linux-info.eclass
index d0a3c96e6b05..864594f607ca 100644
--- a/eclass/linux-info.eclass
+++ b/eclass/linux-info.eclass
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
# @ECLASS: linux-info.eclass
@@ -696,11 +696,17 @@ linux-info_get_any_version() {
die "${FUNCNAME}() called on non-Linux system, please fix the ebuild"
fi
- if ! get_version; then
+ if [[ ${MERGE_TYPE} == binary && -z ${LINUX_INFO_BINARY_RESET} ]]; then
+ unset KV_FULL _LINUX_CONFIG_EXISTS_DONE KV_OUT_DIR
+ LINUX_INFO_BINARY_RESET=1
+ fi
+
+ if [[ ${MERGE_TYPE} != binary ]] && ! get_version; then
ewarn "Unable to calculate Linux Kernel version for build, attempting to use running version"
- if ! get_running_version; then
- die "Unable to determine any Linux Kernel version, please report a bug"
- fi
+ fi
+
+ if [[ -z ${KV_FULL} ]] && ! get_running_version; then
+ die "Unable to determine any Linux Kernel version, please report a bug"
fi
}
diff --git a/eclass/toolchain.eclass b/eclass/toolchain.eclass
index 1cc7000c2377..2acfad8162ac 100644
--- a/eclass/toolchain.eclass
+++ b/eclass/toolchain.eclass
@@ -1347,7 +1347,8 @@ toolchain_src_configure() {
# killing the 32bit builds which want /usr/lib.
export ac_cv_have_x='have_x=yes ac_x_includes= ac_x_libraries='
- confgcc+=( "$@" ${EXTRA_ECONF} )
+ eval "local -a EXTRA_ECONF=(${EXTRA_ECONF})"
+ confgcc+=( "$@" "${EXTRA_ECONF[@]}" )
if ! is_crosscompile && ! tc-is-cross-compiler && [[ -n ${BUILD_CONFIG_TARGETS} ]] ; then
# e.g. ./configure --with-build-config='bootstrap-lto bootstrap-cet'