summaryrefslogtreecommitdiff
path: root/eclass
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-04-15 12:04:03 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-04-15 12:04:03 +0100
commit7fa8a1e3f149eea4c844c47cfe26136ed7614c58 (patch)
treee514d1b9999d088064bee1e34a3a3c500d6d7a07 /eclass
parentd993571e2ee444d08f4e9e90d493ee37338657e3 (diff)
gentoo auto-resync : 15:04:2024 - 12:04:02
Diffstat (limited to 'eclass')
-rw-r--r--eclass/Manifest.gzbin39605 -> 39600 bytes
-rw-r--r--eclass/ant-tasks.eclass2
-rw-r--r--eclass/rpm.eclass63
-rw-r--r--eclass/toolchain.eclass2
4 files changed, 5 insertions, 62 deletions
diff --git a/eclass/Manifest.gz b/eclass/Manifest.gz
index bd2080e0c620..238c0db20016 100644
--- a/eclass/Manifest.gz
+++ b/eclass/Manifest.gz
Binary files differ
diff --git a/eclass/ant-tasks.eclass b/eclass/ant-tasks.eclass
index c1a82ccbab5b..2b10e0f3e1e0 100644
--- a/eclass/ant-tasks.eclass
+++ b/eclass/ant-tasks.eclass
@@ -1,7 +1,7 @@
# Copyright 2007-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-# @DEPRECATED:
+# @DEAD
# @ECLASS: ant-tasks.eclass
# @MAINTAINER:
# java@gentoo.org
diff --git a/eclass/rpm.eclass b/eclass/rpm.eclass
index b9187167eb8f..c9c21aa6ebbd 100644
--- a/eclass/rpm.eclass
+++ b/eclass/rpm.eclass
@@ -1,14 +1,13 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
# @ECLASS: rpm.eclass
# @MAINTAINER:
# base-system@gentoo.org
-# @SUPPORTED_EAPIS: 6 7 8
+# @SUPPORTED_EAPIS: 7 8
# @BLURB: convenience class for extracting RPMs
case ${EAPI} in
- 6) inherit epatch eqawarn ;;
7|8) ;;
*) die "${ECLASS}: EAPI ${EAPI:-0} not supported" ;;
esac
@@ -18,10 +17,7 @@ _RPM_ECLASS=1
inherit estack
-case ${EAPI} in
- 6) DEPEND="app-arch/rpm2targz" ;;
- *) BDEPEND="app-arch/rpm2targz" ;;
-esac
+BDEPEND="app-arch/rpm2targz"
# @FUNCTION: rpm_unpack
# @USAGE: <rpms>
@@ -88,59 +84,6 @@ rpm_src_unpack() {
done
}
-# @FUNCTION: rpm_spec_epatch
-# @USAGE: [spec]
-# @DEPRECATED: none
-# @DESCRIPTION:
-# Read the specified spec (defaults to ${PN}.spec) and attempt to apply
-# all the patches listed in it. If the spec does funky things like moving
-# files around, well this won't handle that.
-rpm_spec_epatch() {
- # no epatch in EAPI 7 and later
- [[ ${EAPI} == 6 ]] || die "${FUNCNAME} is banned in EAPI ${EAPI}"
-
- local p spec=$1
- local dir
-
- if [[ -z ${spec} ]] ; then
- # search likely places for the spec file
- for spec in "${PWD}" "${S}" "${WORKDIR}" ; do
- spec+="/${PN}.spec"
- [[ -e ${spec} ]] && break
- done
- fi
- [[ ${spec} == */* ]] \
- && dir=${spec%/*} \
- || dir=
-
- ebegin "Applying patches from ${spec}"
-
- grep '^%patch' "${spec}" | \
- while read line ; do
- # expand the %patch line
- set -- ${line}
- p=$1
- shift
-
- # process the %patch arguments
- local arg
- EPATCH_OPTS=
- for arg in "$@" ; do
- case ${arg} in
- -b) EPATCH_OPTS+=" --suffix" ;;
- *) EPATCH_OPTS+=" ${arg}" ;;
- esac
- done
-
- # extract the patch name from the Patch# line
- set -- $(grep "^P${p#%p}: " "${spec}")
- shift
- epatch "${dir:+${dir}/}$*"
- done
-
- eend
-}
-
fi
EXPORT_FUNCTIONS src_unpack
diff --git a/eclass/toolchain.eclass b/eclass/toolchain.eclass
index 6a515f9b5c69..0708d3c217fc 100644
--- a/eclass/toolchain.eclass
+++ b/eclass/toolchain.eclass
@@ -2325,7 +2325,7 @@ create_revdep_rebuild_entry() {
#---->> pkg_pre* <<----
toolchain_pkg_preinst() {
- if use test ; then
+ if [[ ${MERGE_TYPE} != binary ]] && use test ; then
# Install as orphaned to allow comparison across more versions even
# after unmerged. Also useful for historical records and tracking
# down regressions a while after they first appeared, but were only