summaryrefslogtreecommitdiff
path: root/eclass
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-07 16:28:34 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-07 16:28:34 +0100
commit2cd907d16458ba3a99ec82155d7268e2d991a078 (patch)
treea49a4ffe10e16f8b619647527716b993c53ea496 /eclass
parent24beafaaa74162a20d550f2ee7c4997724e34d95 (diff)
gentoo auto-resync : 07:09:2023 - 16:28:34
Diffstat (limited to 'eclass')
-rw-r--r--eclass/Manifest.gzbin38489 -> 38494 bytes
-rw-r--r--eclass/qt6-build.eclass6
2 files changed, 6 insertions, 0 deletions
diff --git a/eclass/Manifest.gz b/eclass/Manifest.gz
index 9de8d06de915..fa7d8bcf65e7 100644
--- a/eclass/Manifest.gz
+++ b/eclass/Manifest.gz
Binary files differ
diff --git a/eclass/qt6-build.eclass b/eclass/qt6-build.eclass
index 11e9844346a4..0b4ea6a58ce6 100644
--- a/eclass/qt6-build.eclass
+++ b/eclass/qt6-build.eclass
@@ -98,6 +98,12 @@ qt6-build_src_unpack() {
qt6-build_src_prepare() {
cmake_src_prepare
+ if [[ -e CMakeLists.txt ]]; then
+ # build may be skipped entirely and install nothing without errors
+ # if checking for a major dependency/condition failed
+ sed -i '/message(NOTICE.*Skipping/s/NOTICE/FATAL_ERROR/' CMakeLists.txt || die
+ fi
+
if in_iuse test && use test && [[ -e tests/auto/CMakeLists.txt ]]; then
# upstream seems to install before running tests, and cmake
# subdir that is present in about half of the Qt6 components