summaryrefslogtreecommitdiff
path: root/eclass
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-01 02:21:02 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-01 02:21:02 +0000
commitd682a95de35077b0728025627e082b67339fa249 (patch)
tree39d9937c5811d188bcc3ca56fd3305a42f94fde6 /eclass
parentc4b414ba84991b36b62c066b701385eaf44cdd49 (diff)
gentoo auto-resync : 01:01:2023 - 02:21:02
Diffstat (limited to 'eclass')
-rw-r--r--eclass/Manifest.gzbin37351 -> 37360 bytes
-rw-r--r--eclass/qmail.eclass10
-rw-r--r--eclass/toolchain.eclass4
3 files changed, 6 insertions, 8 deletions
diff --git a/eclass/Manifest.gz b/eclass/Manifest.gz
index 1f5dd0778703..585176bf67cc 100644
--- a/eclass/Manifest.gz
+++ b/eclass/Manifest.gz
Binary files differ
diff --git a/eclass/qmail.eclass b/eclass/qmail.eclass
index 67069087376d..b647ac5d8e3a 100644
--- a/eclass/qmail.eclass
+++ b/eclass/qmail.eclass
@@ -240,7 +240,7 @@ qmail_tcprules_install() {
insinto "${TCPRULES_DIR}"
doins "${GENQMAIL_S}"/tcprules/Makefile.qmail
doins "${GENQMAIL_S}"/tcprules/tcp.qmail-*
- use ssl && use pop3 || rm -f "${D}${TCPRULES_DIR}"/tcp.qmail-pop3sd
+ rm -f "${D}${TCPRULES_DIR}"/tcp.qmail-pop3sd
}
qmail_supervise_install_one() {
@@ -263,7 +263,6 @@ qmail_supervise_install() {
if use pop3; then
qmail_supervise_install_one qmail-pop3d
- use ssl && qmail_supervise_install_one qmail-pop3sd
fi
}
@@ -344,7 +343,7 @@ qmail_rootmail_fixup() {
}
qmail_tcprules_build() {
- for f in tcp.qmail-{smtp,qmtp,qmqp,pop3,pop3s}; do
+ for f in tcp.qmail-{smtp,qmtp,qmqp,pop3}; do
# please note that we don't check if it exists
# as we want it to make the cdb files anyway!
src="${ROOT}${TCPRULES_DIR}/${f}"
@@ -371,11 +370,6 @@ qmail_supervise_config_notice() {
elog "To start the pop3 server as well, create the following link:"
elog "ln -s ${SUPERVISE_DIR}/qmail-pop3d /service/qmail-pop3d"
elog
- if use ssl; then
- elog "To start the pop3s server as well, create the following link:"
- elog "ln -s ${SUPERVISE_DIR}/qmail-pop3sd /service/qmail-pop3sd"
- elog
- fi
fi
elog "Additionally, the QMTP and QMQP protocols are supported, "
elog "and can be started as:"
diff --git a/eclass/toolchain.eclass b/eclass/toolchain.eclass
index 021db270828c..0dd23d93e383 100644
--- a/eclass/toolchain.eclass
+++ b/eclass/toolchain.eclass
@@ -820,6 +820,10 @@ make_gcc_hard() {
# * -z now
# See gcc *_all_extra-options.patch patches.
gcc_hard_flags+=" -DEXTRA_OPTIONS"
+ # Default to -D_FORTIFY_SOURCE=3 instead of -D_FORTIFY_SOURCE=2
+ gcc_hard_flags+=" -DGENTOO_FORTIFY_SOURCE_LEVEL=3"
+ # Add -D_GLIBCXX_ASSERTIONS
+ gcc_hard_flags+=" -DDEF_GENTOO_GLIBCXX_ASSERTIONS"
if _tc_use_if_iuse cet && [[ ${CTARGET} == *x86_64*-linux* ]] ; then
gcc_hard_flags+=" -DEXTRA_OPTIONS_CF"