summaryrefslogtreecommitdiff
path: root/eclass/distutils-r1.eclass
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-23 10:22:15 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-23 10:22:15 +0100
commit8b4ace9c50842c5b83401ea7b179dcab940387e1 (patch)
tree230f3135ceaace633cf93e9838b185c4a6664c2e /eclass/distutils-r1.eclass
parent9ee6d97c2883d42f204a533a8bc1f4562df778fb (diff)
gentoo resync : 23.09.2020
Diffstat (limited to 'eclass/distutils-r1.eclass')
-rw-r--r--eclass/distutils-r1.eclass42
1 files changed, 0 insertions, 42 deletions
diff --git a/eclass/distutils-r1.eclass b/eclass/distutils-r1.eclass
index e0e7a945ab87..25cb67b78a31 100644
--- a/eclass/distutils-r1.eclass
+++ b/eclass/distutils-r1.eclass
@@ -455,47 +455,6 @@ distutils_enable_tests() {
return 0
}
-# @FUNCTION: _distutils-r1_verify_use_setuptools
-# @INTERNAL
-# @DESCRIPTION:
-# Check setup.py for signs that DISTUTILS_USE_SETUPTOOLS have been set
-# incorrectly.
-_distutils_verify_use_setuptools() {
- [[ ${DISTUTILS_OPTIONAL} ]] && return
- [[ ${DISTUTILS_USE_SETUPTOOLS} == manual ]] && return
- [[ ${DISTUTILS_USE_SETUPTOOLS} == pyproject.toml ]] && return
-
- # ok, those are cheap greps. we can try toimprove them if we hit
- # false positives.
- local expected=no
- if [[ ${CATEGORY}/${PN} == dev-python/setuptools ]]; then
- # as a special case, setuptools provides itself ;-)
- :
- elif grep -E -q -s '(from|import)\s+setuptools' setup.py; then
- if grep -E -q -s 'entry_points\s*=' setup.py; then
- expected=rdepend
- elif grep -F -q -s '[options.entry_points]' setup.cfg; then
- expected=rdepend
- elif grep -F -q -s '[entry_points]' setup.cfg; then # pbr
- expected=rdepend
- else
- expected=bdepend
- fi
- fi
-
- if [[ ${DISTUTILS_USE_SETUPTOOLS} != ${expected} ]]; then
- if [[ ! ${_DISTUTILS_SETUPTOOLS_WARNED} ]]; then
- _DISTUTILS_SETUPTOOLS_WARNED=1
- local def=
- [[ ${DISTUTILS_USE_SETUPTOOLS} == bdepend ]] && def=' (default?)'
-
- eqawarn "DISTUTILS_USE_SETUPTOOLS value is probably incorrect"
- eqawarn " value: DISTUTILS_USE_SETUPTOOLS=${DISTUTILS_USE_SETUPTOOLS}${def}"
- eqawarn " expected: DISTUTILS_USE_SETUPTOOLS=${expected}"
- fi
- fi
-}
-
# @FUNCTION: esetup.py
# @USAGE: [<args>...]
# @DESCRIPTION:
@@ -518,7 +477,6 @@ esetup.py() {
[[ ${EAPI} != [45] ]] && die_args+=( -n )
[[ ${BUILD_DIR} ]] && _distutils-r1_create_setup_cfg
- _distutils_verify_use_setuptools
set -- "${EPYTHON:-python}" setup.py "${mydistutilsargs[@]}" "${@}"