summaryrefslogtreecommitdiff
path: root/eclass/distutils-r1.eclass
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-29 21:18:33 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-29 21:18:33 +0100
commit63a4617476a3b084928b38d816b9ed6e196d62f5 (patch)
treef1c7e30e8c9b33d9f7e7b0a2e3dbd1d1121358c4 /eclass/distutils-r1.eclass
parent662f71ae67cd775d7fbb79b5091676c0e07a992b (diff)
gentoo auto-resync : 29:05:2023 - 21:18:33
Diffstat (limited to 'eclass/distutils-r1.eclass')
-rw-r--r--eclass/distutils-r1.eclass27
1 files changed, 18 insertions, 9 deletions
diff --git a/eclass/distutils-r1.eclass b/eclass/distutils-r1.eclass
index ec1dd08b197c..0ccd59fb6c78 100644
--- a/eclass/distutils-r1.eclass
+++ b/eclass/distutils-r1.eclass
@@ -220,7 +220,7 @@ _distutils_set_globals() {
;;
hatchling)
bdep+='
- >=dev-python/hatchling-1.12.2[${PYTHON_USEDEP}]
+ >=dev-python/hatchling-1.17.0[${PYTHON_USEDEP}]
'
;;
jupyter)
@@ -230,7 +230,7 @@ _distutils_set_globals() {
;;
maturin)
bdep+='
- >=dev-util/maturin-0.14.10[${PYTHON_USEDEP}]
+ >=dev-util/maturin-0.14.17[${PYTHON_USEDEP}]
'
;;
no)
@@ -239,7 +239,7 @@ _distutils_set_globals() {
;;
meson-python)
bdep+='
- >=dev-python/meson-python-0.12.0[${PYTHON_USEDEP}]
+ >=dev-python/meson-python-0.12.1[${PYTHON_USEDEP}]
'
;;
pbr)
@@ -249,23 +249,23 @@ _distutils_set_globals() {
;;
pdm)
bdep+='
- >=dev-python/pdm-pep517-1.0.6[${PYTHON_USEDEP}]
+ >=dev-python/pdm-pep517-1.1.4[${PYTHON_USEDEP}]
'
;;
poetry)
bdep+='
- >=dev-python/poetry-core-1.4.0[${PYTHON_USEDEP}]
+ >=dev-python/poetry-core-1.5.2[${PYTHON_USEDEP}]
'
;;
setuptools)
bdep+='
- >=dev-python/setuptools-67.2.0[${PYTHON_USEDEP}]
- >=dev-python/wheel-0.38.4[${PYTHON_USEDEP}]
+ >=dev-python/setuptools-67.7.2[${PYTHON_USEDEP}]
+ >=dev-python/wheel-0.40.0[${PYTHON_USEDEP}]
'
;;
sip)
bdep+='
- >=dev-python/sip-6.7.5-r1[${PYTHON_USEDEP}]
+ >=dev-python/sip-6.7.8[${PYTHON_USEDEP}]
'
;;
standalone)
@@ -600,7 +600,7 @@ distutils_enable_tests() {
test_pkg=">=dev-python/nose-1.3.7_p20221026"
;;
pytest)
- test_pkg=">=dev-python/pytest-7.2.1"
+ test_pkg=">=dev-python/pytest-7.3.1"
;;
setup.py)
;;
@@ -925,6 +925,11 @@ _distutils-r1_print_package_versions() {
dev-python/gpep517
dev-python/installer
)
+ if [[ ${DISTUTILS_EXT} ]]; then
+ packages+=(
+ dev-python/cython
+ )
+ fi
case ${DISTUTILS_USE_PEP517} in
flit)
packages+=(
@@ -1828,6 +1833,10 @@ distutils-r1_run_phase() {
if [[ ${DISTUTILS_EXT} ]]; then
local -x CPPFLAGS="${CPPFLAGS} $(usex debug '-UNDEBUG' '-DNDEBUG')"
+ # always generate .c files from .pyx files to ensure we get latest
+ # bug fixes from Cython (this works only when setup.py is using
+ # cythonize() but it's better than nothing)
+ local -x CYTHON_FORCE_REGEN=1
fi
# How to build Python modules in different worlds...