summaryrefslogtreecommitdiff
path: root/dev-vcs/vcsh/vcsh-2.0.8.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-04-03 08:13:59 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-04-03 08:13:59 +0100
commit2df2e0ebc717aa53904c920c1a361423dfc3a5f7 (patch)
treed81b257b3923100dc55a999dd12b2198a6d35b99 /dev-vcs/vcsh/vcsh-2.0.8.ebuild
parent75abd8d3830449158bdd27f9c4701bcbadc55080 (diff)
gentoo auto-resync : 03:04:2024 - 08:13:58
Diffstat (limited to 'dev-vcs/vcsh/vcsh-2.0.8.ebuild')
-rw-r--r--dev-vcs/vcsh/vcsh-2.0.8.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-vcs/vcsh/vcsh-2.0.8.ebuild b/dev-vcs/vcsh/vcsh-2.0.8.ebuild
new file mode 100644
index 000000000000..84f73bcf6f2e
--- /dev/null
+++ b/dev-vcs/vcsh/vcsh-2.0.8.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Manage config files in \$HOME via fake bare git repositories"
+HOMEPAGE="https://github.com/RichiH/vcsh"
+SRC_URI="https://github.com/RichiH/vcsh/releases/download/v${PV}/${P}.tar.xz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-vcs/git"
+BDEPEND="
+ test? (
+ dev-lang/perl
+ dev-perl/Shell-Command
+ dev-perl/Test-Most
+ )
+"
+
+src_configure() {
+ econf \
+ $(use_enable test tests) \
+ --with-man-page \
+ --with-deployment=${PR}
+}
+
+src_install() {
+ default
+
+ mv "${ED}"/usr/share/doc/${PN} "${ED}"/usr/share/doc/${PF} || die
+
+ dodoc -r doc/sample_hooks
+}