summaryrefslogtreecommitdiff
path: root/dev-vcs/vcsh/vcsh-2.0.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-18 01:55:31 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-18 01:55:31 +0100
commit5fa0e0c7e62842b1491426c8c6e506f51b6c78e1 (patch)
treec494340a21568e82965da87fb559b9133375e762 /dev-vcs/vcsh/vcsh-2.0.4.ebuild
parentd941e0a66c717c1f67ae35cf31afdfcbf7f7acbb (diff)
gentoo auto-resync : 18:10:2022 - 01:55:31
Diffstat (limited to 'dev-vcs/vcsh/vcsh-2.0.4.ebuild')
-rw-r--r--dev-vcs/vcsh/vcsh-2.0.4.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-vcs/vcsh/vcsh-2.0.4.ebuild b/dev-vcs/vcsh/vcsh-2.0.4.ebuild
new file mode 100644
index 000000000000..b6b83219ead8
--- /dev/null
+++ b/dev-vcs/vcsh/vcsh-2.0.4.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Manage config files in $HOME via fake bare git repositories"
+HOMEPAGE="https://github.com/RichiH/vcsh"
+SRC_URI="https://github.com/RichiH/vcsh/releases/download/v${PV}/${P}.tar.xz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-vcs/git"
+
+src_configure() {
+ # bash for https://github.com/RichiH/vcsh/issues/325
+ CONFIG_SHELL="${BROOT}"/bin/bash econf
+}
+
+src_install() {
+ default
+
+ mv "${ED}"/usr/share/doc/${PN} "${ED}"/usr/share/doc/${PF} || die
+
+ dodoc -r doc/sample_hooks
+}