summaryrefslogtreecommitdiff
path: root/dev-vcs/tortoisehg
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-12-01 03:04:39 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-12-01 03:04:39 +0000
commit407525b571b48cfd65e1ad7a02d250a927c967c9 (patch)
tree844bea44d85dc7218f54970af1c42cc9d55c3f1a /dev-vcs/tortoisehg
parent89c6c06b8c42107dd231687a1012354e7d3039fc (diff)
gentoo resync : 01.12.2017
Diffstat (limited to 'dev-vcs/tortoisehg')
-rw-r--r--dev-vcs/tortoisehg/Manifest2
-rw-r--r--dev-vcs/tortoisehg/tortoisehg-4.4.1.ebuild80
2 files changed, 82 insertions, 0 deletions
diff --git a/dev-vcs/tortoisehg/Manifest b/dev-vcs/tortoisehg/Manifest
index 182366bd78b9..7898192dfb02 100644
--- a/dev-vcs/tortoisehg/Manifest
+++ b/dev-vcs/tortoisehg/Manifest
@@ -1,4 +1,6 @@
DIST tortoisehg-4.3.1.tar.gz 7930491 SHA256 5698db60320574769c73e4f910909e75a8e32ba84adcea902f9457899bbcb753 SHA512 dc43f2acd780a7868b642d6ce8a8dbf8f32be94134ddbb72178d7f1eab1e9f58c8e9bcfc75ad589ec9404cabefd9ccfc697af9ccd037c20bd933ee862e812f99 WHIRLPOOL 0275b5d2d76483559d829a6c32b8888af2134fc58367407ff670da21a8d0ae5d98815410520955f41e227af1eb55dd37052af19534756f49d9cb09a91b441de1
+DIST tortoisehg-4.4.1.tar.gz 7923557 BLAKE2B b2574bb87693a3fb824c3c02424b8f5828c1e3673b111ae82ff0692588083eec639a67b200ce6e3def58e5a0e021898c3df62a053fa61d477f92d4226d3a1b69 SHA512 b364e6d16845c03aacaf691e8528e0bd87151026f9f55bcaf61ba67d1eebfc3f9935457e5ca3391e29417682367b9b33803a9870817c22db31f1dd26850e9d53
EBUILD tortoisehg-4.3.1.ebuild 1954 BLAKE2B cfc09db06a657561ea4be0554d5ccefc8b0e9bf743fcc0aac48234a18cea202d3eef204571765f61c0fa39b3645662cf7ab1bcdbd62724f3d2de880bbb7a975e SHA512 5032e7aee5f381edda81e4641bfb37c9a936a1761fc266f2a68d7eb6041076c0c5b5cc007ad60d0836eeb03c23af85870e9b50d4c192eac3f84dce6b6e47c6d2
+EBUILD tortoisehg-4.4.1.ebuild 1956 BLAKE2B 89f32d2806577680d4bd6c0d884c16114e6d9a024910aabc63f8a27ed49209c0340728bdc17f4066664d80d13382d3a769d2ac8a1f0d7570b0c77f4e5e49d4d5 SHA512 42f6e8b2dac0cdf29cc516fbeab65c4a423f3e71e73672f8fee0bb86ed1811dba118b7138423db6d749c60de5390849b9fc63b7440b4a5789723f066501f4523
EBUILD tortoisehg-9999.ebuild 1799 BLAKE2B 1f3c92e5956c8b866377a5f47ceda69a899c399148bdbd45e007f7a89f0b7e5245675e77157714a15ded8f01300bb97f884ba17d3085283a12f307f5028091ef SHA512 b5f0abf784ca30471bab16c253e1a737da021a018de496f3be04917be715e96e1879395061f4c9e790d971f65f113a77bc8a4c8120f8c8036ef565c6ad27ce7a
MISC metadata.xml 251 BLAKE2B 2e2f0363feb3f8ad15ed8d2ef5130493f501acf64faf4fe567079d18a6066c0a1136f6c0cf53ba4ec854a38b5d4211e48e0a2ddac6677ca02266a3f993e36965 SHA512 0ccc4891c6c5de39cbe83d8391b0345611be252a2b1fedea6644ba1cfb283140a8250f32cd26b701db9c60d42782b214d03574592ef3b585bb15d2ffcb5f016e
diff --git a/dev-vcs/tortoisehg/tortoisehg-4.4.1.ebuild b/dev-vcs/tortoisehg/tortoisehg-4.4.1.ebuild
new file mode 100644
index 000000000000..809f95e78063
--- /dev/null
+++ b/dev-vcs/tortoisehg/tortoisehg-4.4.1.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 eutils
+
+if [[ ${PV} != *9999* ]]; then
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="https://www.bitbucket.org/${PN}/targz/downloads/${P}.tar.gz"
+ HG_DEPEND=">=dev-vcs/mercurial-4.3 <dev-vcs/mercurial-4.5"
+else
+ inherit mercurial
+ EHG_REPO_URI="https://bitbucket.org/tortoisehg/thg"
+ EHG_REVISION="stable"
+ HG_DEPEND="dev-vcs/mercurial"
+fi
+
+DESCRIPTION="Set of graphical tools for Mercurial"
+HOMEPAGE="https://tortoisehg.bitbucket.io/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="doc"
+
+RDEPEND="${HG_DEPEND}
+ dev-python/iniparse[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/PyQt4[svg,${PYTHON_USEDEP}]
+ dev-python/qscintilla-python[qt4(+),${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ doc? ( >=dev-python/sphinx-1.0.3 )"
+
+# Workaround race condition in build_qt
+DISTUTILS_IN_SOURCE_BUILD=1
+
+python_prepare_all() {
+ if [[ ${LINGUAS+set} ]]; then
+ cd i18n/tortoisehg || die
+ local x y keep
+ for x in *.po; do
+ keep=false
+ for y in ${LINGUAS}; do
+ if [[ ${y} == ${x%.po}* ]]; then
+ keep=true
+ break
+ fi
+ done
+ ${keep} || rm "${x}" || die
+ done
+ cd "${S}" || die
+ fi
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C doc html
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ dodoc doc/ReadMe*.txt doc/TODO contrib/mergetools.rc
+ if use doc ; then
+ docinto html
+ dodoc -r doc/build/html/
+ fi
+ newicon -s scalable icons/scalable/apps/thg.svg thg_logo.svg
+ domenu contrib/thg.desktop
+
+ # Remove file that collides with >=mercurial-4.0 (bug #599266).
+ rm "${ED}"/usr/$(get_libdir)/${EPYTHON}/site-packages/hgext3rd/__init__.py \
+ || die
+}
+
+pkg_postinst() {
+ elog "When startup of ${PN} fails with an API version mismatch error"
+ elog "between dev-python/sip and dev-python/PyQt4 please rebuild"
+ elog "dev-python/qscintilla-python."
+}