summaryrefslogtreecommitdiff
path: root/dev-vcs/topgit/topgit-0.19.12.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /dev-vcs/topgit/topgit-0.19.12.ebuild
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'dev-vcs/topgit/topgit-0.19.12.ebuild')
-rw-r--r--dev-vcs/topgit/topgit-0.19.12.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-vcs/topgit/topgit-0.19.12.ebuild b/dev-vcs/topgit/topgit-0.19.12.ebuild
new file mode 100644
index 000000000000..eab7ae62e258
--- /dev/null
+++ b/dev-vcs/topgit/topgit-0.19.12.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit bash-completion-r1
+
+DESCRIPTION="A different patch queue manager"
+HOMEPAGE="https://mackyle.github.io/topgit/topgit.html https://github.com/mackyle/topgit"
+SRC_URI="https://github.com/mackyle/${PN}/archive/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="sys-apps/sed
+ virtual/awk"
+RDEPEND=">=dev-vcs/git-2.10.0"
+
+S="${WORKDIR}/${PN}-${P}"
+
+src_compile() {
+ # Needed because of "hardcoded" paths
+ emake prefix="/usr" sharedir="/usr/share/doc/${PF}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" prefix="/usr" sharedir="/usr/share/doc/${PF}" install
+
+ newbashcomp contrib/tg-completion.bash tg
+ dodoc README
+}